Bug 8503 - Software error n edit items with EasyAnalyticalRecords
Summary: Software error n edit items with EasyAnalyticalRecords
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low major (vote)
Assignee: Fridolin SOMERS
QA Contact: Jonathan Druart
URL:
Keywords:
: 8699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-25 11:29 UTC by Fridolin SOMERS
Modified: 2013-05-23 06:23 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.77 KB, patch)
2012-07-25 12:17 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 8503: Software error in edit items with EasyAnalyticalRecords (1.95 KB, patch)
2012-07-28 13:23 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2012-07-25 11:29:20 UTC
When editing some records, the editing items returns an error : 
"Software error:
Can't call method "field" on an undefined value at /home/koha/src/cataloguing/additem.pl line 570."

(MT9859)
Comment 1 Fridolin SOMERS 2012-07-25 12:17:45 UTC Comment hidden (obsolete)
Comment 2 Fridolin SOMERS 2012-07-25 12:27:18 UTC
Test plan:
----------

Activate 'EasyAnalyticalRecords' syspref.
Edit a record on a framework containing visible : 773$0 for MARC21/NORMARC, 461$0 for UNIMARC.
Use in this subfield a value that does not correspond to an existing biblionumber.
Save the record.
Go to "edit items".
=> Without patch : software error
=> With patch : no error
Comment 3 Jared Camins-Esakov 2012-07-28 13:23:06 UTC
Created attachment 11181 [details] [review]
Bug 8503: Software error in edit items with EasyAnalyticalRecords

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Solves software error when editing items for record with invalid
analytic.
Comment 4 Jonathan Druart 2012-07-30 09:02:56 UTC
QA Comments:

Maybe we want to add a log line if something is wrong, isn't it ?
Comment 5 Jared Camins-Esakov 2012-07-30 13:13:20 UTC
(In reply to comment #4)
> QA Comments:
> 
> Maybe we want to add a log line if something is wrong, isn't it ?

I don't think so, no. Someone may be storing other data in subfield $0.
Comment 6 Jonathan Druart 2012-07-30 13:42:34 UTC
(In reply to comment #5)
> I don't think so, no. Someone may be storing other data in subfield $0.

ok, so marking as Passed QA.
Comment 7 Chris Cormack 2012-08-01 23:41:33 UTC
Pushed to 3.8.x will be in 3.8.4
Comment 8 Fridolin SOMERS 2012-09-24 15:40:20 UTC
*** Bug 8699 has been marked as a duplicate of this bug. ***