Bug 8520 - Authorities display incorrectly in staff results
Summary: Authorities display incorrectly in staff results
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low critical (vote)
Assignee: Jared Camins-Esakov
QA Contact: Marcel de Rooy
URL:
Keywords:
: 8386 8555 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-30 13:21 UTC by Jared Camins-Esakov
Modified: 2019-06-27 09:24 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8520: fix authority display in staff client (1.16 KB, patch)
2012-07-30 13:25 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8520: fix authority display in staff client (1.21 KB, patch)
2012-08-01 18:26 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 8520: fix authority display in autocomplete (877 bytes, patch)
2012-08-07 14:48 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8520: fix authority display in autocomplete (882 bytes, patch)
2012-08-07 14:51 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8520: fix authority display in autocomplete (1022 bytes, patch)
2012-08-07 14:56 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8520: fix authority display in autocomplete (1.05 KB, patch)
2012-08-07 14:59 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 8520 - Authorities summary incorrect on posible duplicate notice (1.16 KB, patch)
2012-09-03 18:05 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 8520 - Authorities summary incorrect on posible duplicate notice (1.17 KB, patch)
2012-09-04 09:07 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-07-30 13:21:07 UTC
Instead of the main entry, authority results on the staff client show things like:
"HASH(0xadef408)
    used for/see from: Smithsonian Institution. Arthur M. Sackler Gallery
    used for/see from: Sackler Gallery (Smithsonian Institution)"
Comment 1 Jared Camins-Esakov 2012-07-30 13:25:53 UTC Comment hidden (obsolete)
Comment 2 Tomás Cohen Arazi 2012-08-01 18:26:45 UTC Comment hidden (obsolete)
Comment 3 Jared Camins-Esakov 2012-08-02 11:33:26 UTC
Marking as signed off, since it already was.
Comment 4 Jared Camins-Esakov 2012-08-02 11:33:48 UTC
*** Bug 8555 has been marked as a duplicate of this bug. ***
Comment 5 Marcel de Rooy 2012-08-02 11:38:05 UTC
Passed QA
Comment 6 Paul Poulain 2012-08-02 13:39:06 UTC
Well done !
Comment 7 Tomás Cohen Arazi 2012-08-02 14:33:25 UTC
Please push. Affects 3.8 installs too.
Comment 8 Paul Poulain 2012-08-02 14:37:52 UTC
(In reply to comment #7)
> Please push. Affects 3.8 installs too.

I changed the version, for chris_c
Comment 9 Chris Cormack 2012-08-02 21:56:34 UTC
Pushed to 3.8.x, will be in 3.8.4
Comment 10 Jared Camins-Esakov 2012-08-07 14:48:06 UTC Comment hidden (obsolete)
Comment 11 Jared Camins-Esakov 2012-08-07 14:51:59 UTC Comment hidden (obsolete)
Comment 12 Jared Camins-Esakov 2012-08-07 14:56:12 UTC Comment hidden (obsolete)
Comment 13 Tomás Cohen Arazi 2012-08-07 14:59:58 UTC Comment hidden (obsolete)
Comment 14 Mason James 2012-08-10 04:57:35 UTC
hmmm, this patch has already passed QA. i think there is no need to QA it again

changing status ready for 'push to 3.8'
Comment 15 Mason James 2012-08-10 05:04:10 UTC
(In reply to comment #10)
> Created attachment 11420 [details] [review]
> Bug 8520: fix authority display in autocomplete


Jared, this patch is surely for another bug? yes?
Comment 16 Jared Camins-Esakov 2012-08-10 09:12:02 UTC
(In reply to comment #15)
> (In reply to comment #10)
> > Created attachment 11420 [details] [review]
> > Bug 8520: fix authority display in autocomplete
> 
> 
> Jared, this patch is surely for another bug? yes?

No, same bug.
Comment 17 Tomás Cohen Arazi 2012-08-10 14:45:18 UTC
The second patch is a neede follow up.
Comment 18 Marcel de Rooy 2012-08-11 17:24:58 UTC
Attachment 11423 [details]: Passed QA
Comment 19 Tomás Cohen Arazi 2012-08-21 15:27:02 UTC
Needs to be pushed, on 3.8.x TOO!
Comment 20 Chris Cormack 2012-08-21 20:53:38 UTC
(In reply to comment #19)
> Needs to be pushed, on 3.8.x TOO!

Hasn't been pushed to master yet. Once its pushed to master ill push it to 3.8.x
Comment 21 Paul Poulain 2012-08-28 16:01:41 UTC
mmm... I can't find how to test this follow-up for autocomplete. Tomas, I'm back from holiday, not completly awaken it seems, if you can share the light with me ...
Comment 22 Tomás Cohen Arazi 2012-08-28 16:04:28 UTC
(In reply to comment #21)
> mmm... I can't find how to test this follow-up for autocomplete. Tomas, I'm
> back from holiday, not completly awaken it seems, if you can share the light
> with me ...

Paul, typing something in any of the authority search fields (tested from cataloguing) should be enough. Without the patch you should see HASH(0x...) if using the autocomplete function. With the patch you will see the correct results.
Comment 23 Jared Camins-Esakov 2012-08-28 16:05:56 UTC
(In reply to comment #21)
> mmm... I can't find how to test this follow-up for autocomplete. Tomas, I'm
> back from holiday, not completly awaken it seems, if you can share the light
> with me ...

Use autocomplete in the auth_finder plugin. Without the patch applied, you get gibberish in the dropdown. With the patch, you get valid headings. This is somewhat dependent on how fast your system is. Something happened to my VM and it no longer manages to do autocomplete. In order to test this I had to point my web browser to the autocomplete URL.
Comment 24 Paul Poulain 2012-08-31 13:33:18 UTC
OK, got it ! patch pushed
Comment 25 Chris Cormack 2012-09-01 02:56:49 UTC
Pushed to 3.8.x, will be in 3.8.5
Comment 26 Tomás Cohen Arazi 2012-09-03 18:05:16 UTC Comment hidden (obsolete)
Comment 27 Chris Cormack 2012-09-04 09:07:01 UTC
Created attachment 11955 [details] [review]
Bug 8520 - Authorities summary incorrect on posible duplicate notice

We didn't notice this one with jcamins when we fixed this bug.

Sponsored-by: Universidad Nacional de Córdoba
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 28 Jared Camins-Esakov 2012-09-10 19:02:56 UTC
*** Bug 8386 has been marked as a duplicate of this bug. ***
Comment 29 Mason James 2012-09-14 12:24:54 UTC
> Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

patch looks good, passing QA…

$ koha-qa.pl  

testing 1 commit(s) (applied to commit 0acebb8)
 * 119fb5f Bug 8520 - Authorities summary incorrect on posible duplicate not
      authorities/authorities.pl

* authorities/authorities.pl                                               OK
Comment 30 Paul Poulain 2012-09-14 15:39:31 UTC
follow-up  "Bug 8520 - Authorities summary incorrect on posible duplicate notice (1.17 KB, patch) " pushed
Comment 31 Chris Cormack 2012-09-16 08:46:07 UTC
Pushed to 3.8.x, will be in 3.8.5