Bug 8537 - In moremember.pl the call of output_pref is without check
Summary: In moremember.pl the call of output_pref is without check
Status: RESOLVED DUPLICATE of bug 8532
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Christophe Croullebois
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-31 14:11 UTC by Christophe Croullebois
Modified: 2012-08-06 12:37 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch (1.10 KB, patch)
2012-07-31 14:28 UTC, Christophe Croullebois
Details | Diff | Splinter Review
Bug 8537 : In moremember.pl the call of 'output_pref' is without check (1.15 KB, patch)
2012-08-06 09:17 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Croullebois 2012-07-31 14:11:57 UTC
A case I meet with a customer's borrower, the argument passed to the sub, could be undefined,  in this case koha is not happy.
I just put a condition, the same logic than for the line below.
To test :
you need to have in moremember.pl a borrower that returns 'undefined' for '$issue->{date_due}' with GetPendingIssues.
Or read the code I think it is clear.
Thx.
Comment 1 Christophe Croullebois 2012-07-31 14:28:56 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2012-08-06 09:17:45 UTC
Created attachment 11376 [details] [review]
Bug 8537 : In moremember.pl the call of 'output_pref' is without check

the argument passed to "output_pref", could be undefined,  in this case koha is not happy.
I just put a condition, the same logic than for the line below.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 3 Jonathan Druart 2012-08-06 12:37:35 UTC
QA Comments:

This patch becomes useless with the patch proposed by Robin for Bug 8532.

I mark this one as Resolved

*** This bug has been marked as a duplicate of bug 8532 ***