Bug 8551 - Course reserves
Summary: Course reserves
Status: RESOLVED DUPLICATE of bug 8215
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Maxime Pelletier
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-01 20:09 UTC by Maxime Pelletier
Modified: 2013-03-13 17:52 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Screenshot of the intranet interface to add an item (sry it's in french :P) (13.85 KB, image/png)
2012-08-01 20:12 UTC, Maxime Pelletier
Details
OPAC page (using datatables) (180.33 KB, image/png)
2012-08-01 20:13 UTC, Maxime Pelletier
Details
First version of the patch (26.25 KB, patch)
2012-08-01 20:15 UTC, Maxime Pelletier
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime Pelletier 2012-08-01 20:09:10 UTC
New functionnality to add a status Reserved for the Not For Loan field of items. It also adds fields to add the name of the Teacher and the Course.
It adds a new page in the OPAC to list all the items that have this status.

The functionnality looks like what is in bug #8215, but it's much more simple. It was also one of the first features I added to koha, so it really lacks comments, isn't based on master (based on 3.8.2) and doesn't have database updates yet.
I'm posting it here to see if there's any interest and to have feedback on how I did the functionnality.

Thanks.
Comment 1 Maxime Pelletier 2012-08-01 20:12:32 UTC
Created attachment 11275 [details]
Screenshot of the intranet interface to add an item (sry it's in french :P)
Comment 2 Maxime Pelletier 2012-08-01 20:13:00 UTC
Created attachment 11276 [details]
OPAC page (using datatables)
Comment 3 Maxime Pelletier 2012-08-01 20:15:52 UTC
Created attachment 11277 [details] [review]
First version of the patch
Comment 4 Maxime Pelletier 2012-08-01 20:17:59 UTC
Also I believe there's no page using Datatables in the OPAC. I had to fix the images paths and copy some images from the intranet img folder. Should I just open this as a separate bug report ?
Comment 5 Maxime Pelletier 2013-03-13 17:52:56 UTC
marking as duplicate because 8215 has way better chances to make it and has way more features

*** This bug has been marked as a duplicate of bug 8215 ***