Bug 8570 - Add pagination to the Z39.50 results page
Summary: Add pagination to the Z39.50 results page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Z39.50 / SRU / OpenSearch Servers (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Frédérick Capovilla
QA Contact:
URL:
Whiteboard:
Keywords:
: 5044 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-03 18:01 UTC by Frédérick Capovilla
Modified: 2013-12-05 20:01 UTC (History)
6 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Add paginations to the Z39.50 search results. (13.96 KB, patch)
2012-08-03 18:01 UTC, Frédérick Capovilla
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8570 - Add pagination to the Z39.50 results page (14.15 KB, patch)
2012-08-17 15:25 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Frédérick Capovilla 2012-08-03 18:01:04 UTC Comment hidden (obsolete)
Comment 1 Frédérick Capovilla 2012-08-03 18:02:32 UTC
Patch sponsored by the CCSR ( http://www.ccsr.qc.ca )
Comment 2 Owen Leonard 2012-08-03 18:31:10 UTC
*** Bug 5044 has been marked as a duplicate of this bug. ***
Comment 3 Owen Leonard 2012-08-03 19:08:14 UTC
I am really happy to see this long-missing feature added, but I'm not so happy to see an entirely new method of offering the user pagination options. Currently we have two primary ways of offering pagination options: The plain link kind (as seen on catalog search results) and the DataTables way. It would be much, much better in my opinion to pick one of these established interface patterns than to introduce a whole new one.
Comment 4 Frédérick Capovilla 2012-08-03 19:27:33 UTC
This feature was made a long time ago and got approved for release to the community by our client recently.

There is no doubt using the existing patterns would be the best way to do this, but for now all we have is a working version with it's own pagination method.
Comment 5 Owen Leonard 2012-08-17 15:25:06 UTC
Created attachment 11671 [details] [review]
[SIGNED-OFF] Bug 8570 - Add pagination to the Z39.50 results page

Add paginations to the Z39.50 search results.

http://bugs.koha-community.org/show_bug.cgi?id=8570
Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 6 Paul Poulain 2012-09-19 14:08:46 UTC
QA comment: I'm really annoyed, as Owen is, to see that this patch does not use datatable... It's an improvement expected since a long time OTOH.

We have:
 * Owen = yes
 * Paul = would prefer no and ask for another patch, that could never be submitted
 * another one opinion ?

PS: "This feature was made a long time ago and got approved for release to the community by our client recently."
I think this is a wrong way to do with customers. You should say *before* the contract that everything will be released ASAP.
That's how we do at BibLibre, librarians are OK with that. We even put everything on a public git repo before the development is done.

If you ask *after*, they will ask their legal advisor, and it will take a long time
(but I'm french, maybe it's different in north-america...)
Comment 7 Owen Leonard 2012-09-19 15:38:24 UTC
(In reply to comment #6)
>  * Paul = would prefer no and ask for another patch, that could never be
> submitted

I get the impression that this implementation is good enough for the original sponsor and that a follow-up is unlikely. I signed off because I think getting this functionality into Koha is important, despite my reservations about the way it was done.
Comment 8 Marc Véron 2012-09-19 16:18:43 UTC
Agree with Owen.

Marc
Comment 9 Paul Poulain 2012-10-09 15:35:35 UTC
QA comment
 * passes koha-qa.pl after fixing some remaining tabs in the code, i've added a follow-up
 * passed QA
Comment 10 Paul Poulain 2012-10-09 15:35:52 UTC
Patch pushed to master