Bug 8571 - Add search suggestions on the OPAC ("Did you mean?" feature)
Summary: Add search suggestions on the OPAC ("Did you mean?" feature)
Status: RESOLVED DUPLICATE of bug 8209
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Frédérick Capovilla
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-03 18:59 UTC by Frédérick Capovilla
Modified: 2018-02-12 21:25 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Add search suggestions to search results on the OPAC. (4.56 KB, patch)
2012-08-03 18:59 UTC, Frédérick Capovilla
Details | Diff | Splinter Review
Bug 8571: Add search suggestions to search results on the OPAC. (5.36 KB, patch)
2015-05-26 04:52 UTC, M. Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Frédérick Capovilla 2012-08-03 18:59:11 UTC Comment hidden (obsolete)
Comment 1 Frédérick Capovilla 2012-08-03 19:00:05 UTC
Patch sponsored by the CCSR ( http://www.ccsr.qc.ca )
Comment 2 Owen Leonard 2012-08-03 19:09:31 UTC
A duplicate of Bug 8209?
Comment 3 Jane Wagner 2012-08-03 19:16:49 UTC
Duplicate of Bug 4240
Comment 4 Jared Camins-Esakov 2012-08-03 20:04:44 UTC
Actually, I disagree with both the earlier suggestions. I think this is a duplicate of bug 7417, since the idea is that it will suggest relevant records based on see from fields in authority records.
Comment 5 Jared Camins-Esakov 2012-08-03 20:11:52 UTC
(In reply to comment #4)
> Actually, I disagree with both the earlier suggestions. I think this is a
> duplicate of bug 7417, since the idea is that it will suggest relevant
> records based on see from fields in authority records.

To clarify, I think the end result is closer to bug 7417, even though the display looks more like 8209.
Comment 6 Katrin Fischer 2014-11-02 11:29:37 UTC
Not sure which this is a duplicate of... but now that we removed the prog OPAC template, this will need some work.
Comment 7 M. Tompsett 2015-05-26 04:52:08 UTC
I rescued this, but I'm doubting if this is even needed. Perhaps it is best marked as a resolved duplicate of something?
Comment 8 M. Tompsett 2015-05-26 04:52:46 UTC
Created attachment 39498 [details] [review]
Bug 8571: Add search suggestions to search results on the OPAC.

This patch will add search suggestions at the beginning of
search results on the OPAC if the "OPACSearchSuggestions"
preference is activated. This feature can be compared to
"Did you mean?" or autocorrect features in search engines.

Authorities records are used as a source of suggestions.
The search terms the user entered are used in a "see also"
authority search to find suggestions.
Comment 9 Eric Phetteplace 2017-11-27 22:34:02 UTC
It seems like this feature is now included in Koha. OK to close the bug? Or is this useful as a general discussion place for the feature? I wanted to comment on another, more specific, issue as I think we can agree Koha now does search suggestions but the manner in which it does so can be discussed separately.
Comment 10 Katrin Fischer 2018-02-12 21:25:51 UTC
I think this can be closed in favor or a more specific bug - looking at the code it seems very similar to the did you mean plugins.

*** This bug has been marked as a duplicate of bug 8209 ***