Bug 8667 - Add budget and branch columns in histsearch.pl results
Summary: Add budget and branch columns in histsearch.pl results
Status: CLOSED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Julian Maurice
QA Contact:
URL:
Keywords:
Depends on: 5336 7290
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 13:56 UTC by Julian Maurice
Modified: 2014-12-07 20:02 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8667: Add budget and branch columns in histsearch.pl results (2.61 KB, patch)
2012-08-22 14:10 UTC, Julian Maurice
Details | Diff | Splinter Review
Bug 8667: Add budget and branch columns in histsearch.pl results (2.56 KB, patch)
2013-01-10 09:20 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Maurice 2012-08-22 13:56:17 UTC

    
Comment 1 Julian Maurice 2012-08-22 14:10:49 UTC Comment hidden (obsolete)
Comment 2 Koha Team University Lyon 3 2012-08-22 15:23:53 UTC
Test with a sandbox.

Just do 3 acquisitions and then try to search them in order search : it doesn't return any result
Comment 3 Julian Maurice 2012-08-23 07:48:50 UTC
I am not able to reproduce the problem. But I can see on your sandbox (Salers) that all orders are linked to a deleted bibliographic record, so maybe this can alter the results. Also if you leave all search fields empty it should returns all orders.
Can you please retry with another set of orders?
Comment 4 Koha Team University Lyon 3 2012-08-23 07:59:42 UTC
I have changed the patch on sandbox Salers (7919 at this time). When testing, I have done 3 new acquisitions. I'll repeat this test later today and I'll mention it in bugzilla
Comment 5 Koha Team University Lyon 3 2012-08-23 10:30:44 UTC
sandbox Salers is ready with this patch and I have done several acquisitions (basket#4 "test patch8667" and basket#5 "test patch8667-2")
If you can check.... I have no result when I do an order search.
Thanks
Comment 6 Julian Maurice 2012-08-23 11:56:06 UTC
Ok, my fault... This patch depends on another one (Bug 7290).
Sorry.
Comment 7 Julian Maurice 2012-09-14 14:54:05 UTC
I reset status to needs signoff, but this bug still depends on bug 7290 so it can't be tested on a sandbox.
Comment 8 Julian Maurice 2013-01-10 09:20:50 UTC
Created attachment 14519 [details] [review]
Bug 8667: Add budget and branch columns in histsearch.pl results

Rebased on master
Comment 9 mathieu saby 2013-03-21 21:35:47 UTC
This patch reaks the search in histsearch.pl : after I have applied it, I could not get any result when searching all the orders in a basket or linked to a vendor.

M. Saby
Comment 10 Jonathan Druart 2013-03-22 11:29:57 UTC
Blocked by bug 7294 (for the aqorders.branchcode columns).
Comment 11 Jonathan Druart 2013-04-09 15:59:39 UTC
Blocked by bug 5336 (for the aqorders.branchcode columns).
Comment 12 Jonathan Druart 2013-04-23 13:11:17 UTC
The fund column is added by bug 5336
Comment 13 Jonathan Druart 2013-10-04 13:16:13 UTC
(In reply to Jonathan Druart from comment #11)
> Blocked by bug 5336 (for the aqorders.branchcode columns).

Bug 5336 will be pushed *without* the aqorders.branchcode column!
Comment 14 Jonathan Druart 2013-10-28 10:41:46 UTC
aqorders.branchcode won't exist and the fund column has been added by bug 5336.