Bug 8743 - ZOOM error when merging authority change to biblios
Summary: ZOOM error when merging authority change to biblios
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: 3.8
Hardware: All All
: P3 critical (vote)
Target Milestone: Oldversions
Assignee: Jared Camins-Esakov
QA Contact: Mason James
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-09 12:10 UTC by Jared Camins-Esakov
Modified: 2018-12-16 19:34 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8743: ZOOM error when merging authority change to biblios (2.70 KB, patch)
2012-09-09 12:20 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 8743: ZOOM error when merging authority change to biblios (2.90 KB, patch)
2012-09-10 18:54 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2012-09-09 12:10:14 UTC
The symptoms of the problem are as follows:

In the log file, we get the following errors:
[Sun Sep 02 23:38:10 2012] [error] [client 75.149.175.233] ZOOM error 25
"Specified element set name not valid for specified database" (addinfo:
"F") from diag-set 'Bib-1', referer:
http://****/cgi-bin/koha/authorities/authorities.pl?authid=3010
[Sun Sep 02 23:38:11 2012] [error] [client 75.149.175.233] Premature end of
script headers: authorities.pl, referer:
http://****/cgi-bin/koha/authorities/authorities.pl?authid=3010

The actual authority record was updated (here I added a bogus 'J').
=LDR  00372nz  a2200133o  4500
=001  3010
=003  UkLoVW
=005  20120902233810.0
=008  120816|||a||||||\\\\\\\\\\\|\|||\\\\\d
=040  \\$aUkLoVW$cUkLoVW
=100  1\$aBearman, C. JJ.
=667  \\$aMachine generated authority record.
=670  \\$aWork cat.: (UkLoVW): Stealens, Yvette 3009, Hampshire folk map :,
2010.
=942  \\$aPERSO_NAME

A search in Authorities for 'Bearman" returns this (the old contents), but
following details gets updated record:
Authority search results

Results 1 to 1 of 1
 Summary Used in Delete Bearman, C. J.
Details
3
biblio(s)

Biblios are likewise not update with the new text.
Running 'rebuild_zebra.pl -a -r -v' fixed the Authority search results, but
not the biblios, in particular the 700 field where Bearman is listed as a
secondary author.
Same issue if I modify the primary author Authority on a biblio, the
biblios are not updated with the changed content.

The cause for this seems to be the use of the xml syntax in the merge function. git bisect failed me, but sometime before 3.8.0 (possibly last November), our Zebra config changed and the xml syntax stopped working.
Comment 1 Jared Camins-Esakov 2012-09-09 12:20:27 UTC Comment hidden (obsolete)
Comment 2 Jared Camins-Esakov 2012-09-10 18:54:26 UTC
Created attachment 12119 [details] [review]
Bug 8743: ZOOM error when merging authority change to biblios

The merge fails and the following errors appear in the log:
[Sun Sep 02 23:38:10 2012] [error] [client 75.149.175.233] ZOOM error 25
"Specified element set name not valid for specified database" (addinfo:
"F") from diag-set 'Bib-1', referer:
http://****/cgi-bin/koha/authorities/authorities.pl?authid=3010
[Sun Sep 02 23:38:11 2012] [error] [client 75.149.175.233] Premature end of
script headers: authorities.pl, referer:
http://****/cgi-bin/koha/authorities/authorities.pl?authid=3010

Test plan:
1) Set dontmerge to "Do"
2) Find an authority that is linked to a bib record.
3) Edit the main entry of the authority.
4) Save the authority record.
5) Notice that you got a nasty error and the bib record was not updated.
6) Apply patch.
7) Edit the main entry of the authority again (you can just set it back
   to what it was to start with).
8) Save authority record.
9) Notice that there was no error, and the bib record was updated.
10) Sign off.
Comment 3 Doug Kingston 2012-09-12 01:56:44 UTC
Comment on attachment 12119 [details] [review]
Bug 8743: ZOOM error when merging authority change to biblios

I can confirm that this patch has fixed our failure to update biblios cited at the beginning of this bug.  Thanks for the patch Jared!
Comment 4 Chris Cormack 2012-09-12 02:09:35 UTC
Do you want to sign off on it Doug?
Comment 5 Doug Kingston 2012-09-13 02:18:03 UTC
I have tested this and completely fixes the problem described.  Tested on a 3.08.4 system.  Patch applied cleanly.
Comment 6 Mason James 2012-09-14 07:03:51 UTC
Comment on attachment 12080 [details] [review]
Bug 8743: ZOOM error when merging authority change to biblios

obsoleting patch
Comment 7 Mason James 2012-09-14 07:05:40 UTC
(In reply to comment #5)
> I have tested this and completely fixes the problem described.  Tested on a
> 3.08.4 system.  Patch applied cleanly.

patch signed off, passing QA...

$ koha-qa.pl 

testing 1 commit(s) (applied to commit 60790d0)
 * 797e722 Bug 8743: ZOOM error when merging authority change to biblios
      C4/AuthoritiesMarc.pm

* C4/AuthoritiesMarc.pm                                                    OK
Comment 8 Paul Poulain 2012-09-14 14:00:33 UTC
Patch pushed to master

Bug existing also in 3.8 ?
Comment 9 Chris Cormack 2012-09-16 08:27:11 UTC
Pushed to 3.8.x, will be in 3.8.5