Bug 8780 - Lower dependency version for DateTime::TimeZone
Summary: Lower dependency version for DateTime::TimeZone
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 3.8
Hardware: All All
: P1 - high major (vote)
Assignee: M. Tompsett
QA Contact: Mason James
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-18 04:47 UTC by M. Tompsett
Modified: 2014-05-26 21:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
DateTime::TimeZone min_ver=1.20 from 1.26 (1.10 KB, patch)
2012-09-18 08:33 UTC, M. Tompsett
Details | Diff | Splinter Review
SIGNED-OFF-Bug-8780-Lower-dependency-version-for-DateTime-TimeZone (1.12 KB, patch)
2012-09-19 04:57 UTC, wajasu
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description M. Tompsett 2012-09-18 04:47:01 UTC
A base Debian install of 6.0.5 has a DateTime::TimeZone version 1.20 available (including debian.koha-community.org repositories), but the PerlDependencies.pm says 1.26

After discussions on the IRC channel (http://irc.koha-community.org/irclog/koha/2012-09-17) from 08:50-09:35 and 12:44-13:07, I decided to email Colin Campbell.

He replied:
"No its a nominal number. Looking through the changes log nearly all
changes up to current (1.50) are just updates to reflect data changes in
some timezones. We're mainly using it for the timezone names so I think
1.20 will be fine.
I think the only reason a number was chosen was because one of the
install routines didnt allow us just to say any DateTime::TimeZone
Cheers
Colin"

Given that Colin says it should be okay to lower it to 1.20, and that Wajasu has purposefully tweaked his out since June (almost 3 months), I propose we lower the minimum value to 1.20 from 1.26. This will make git installs under Debian attainable.

Test
-----
1) Do a fresh git clone on Debian.
2) cd the clone.
3) sudo apt-get install dselect
4) sudo dpkg --set-selections < install_misc/debian.packages
5) sudo dselect
6) choose I, C, R, and then Q.
7) ./koha_perl_deps.pl -m -u
8) Notice that despite being installed, DateTime::TimeZone is 1.20 vs. the required 1.26

now apply patch
9) ./koha_perl_deps.pl -m -u
10) Notice that DateTime::TimeZone is no longer listed.

As for the other items, that can be fixed by running my check_deps.sh script which is in the release-tools repo (I believe), and as such, is another bug report.
Comment 1 M. Tompsett 2012-09-18 08:33:16 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2012-09-18 16:26:56 UTC
Not fully tested, but with an existing Koha installation (master) I do not longer have a warning regarding DateTime::TimeZone (orange color) on the about page's Perl tab.

Not enough to sign off, I'm afraid.

Marc
Comment 3 wajasu 2012-09-19 04:57:24 UTC
Created attachment 12325 [details] [review]
SIGNED-OFF-Bug-8780-Lower-dependency-version-for-DateTime-TimeZone

I've been dropping the version back for squeeze for two months now(Jul/Aug/Sept 2012), or all my dev and standard installs. No significant difference that I've seen.

Thanks mtompset!  One less diversion or hangup for folks.

wajasu

Note: It would be nice if it gets on 3.8.x and master for 3.10.
Comment 4 Mason James 2012-09-25 10:48:03 UTC
> SIGNED-OFF-Bug-8780-Lower-dependency-version-for-DateTime-TimeZone

based on the info from Colin and wajasu, im happy to pass QA on this
nice spotting Mark :)

$ koha-qa.pl -c 1

testing 1 commit(s) (applied to commit bd1f621)
 * 926840c Bug 8780 - Lower dependency version for DateTime::TimeZone
      C4/Installer/PerlDependencies.pm

* C4/Installer/PerlDependencies.pm                                         OK
Comment 5 Paul Poulain 2012-09-26 16:58:58 UTC
Patch pushed to master
Comment 6 Chris Cormack 2013-04-20 23:01:21 UTC
Pushed to 3.8.x will be in 3.8.12