Bug 8796 - patron cards not starting on designated card
Summary: patron cards not starting on designated card
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P3 normal (vote)
Assignee: Marc Véron
QA Contact: Mason James
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-20 11:59 UTC by Nicole C. Engard
Modified: 2015-12-03 22:11 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Starting labels on positions 2 and 7 (on the label sheet) (204.25 KB, image/jpeg)
2012-09-24 20:06 UTC, Marc Véron
Details
Bug 8796 - patron cards not starting on designated card (2.48 KB, patch)
2012-09-24 20:25 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8796 - patron cards not starting on designated card (2.53 KB, patch)
2012-09-28 12:45 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 8796 - patron cards not starting on designated card (2.97 KB, patch)
2015-03-29 09:57 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 8796 - patron cards not starting on designated card (3.04 KB, patch)
2015-03-30 06:10 UTC, Josef Moravec
Details | Diff | Splinter Review
[PASSED QA] Bug 8796 - patron cards not starting on designated card (3.10 KB, patch)
2015-04-06 09:33 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8796 - patron cards not starting on designated card (3.13 KB, patch)
2015-04-09 16:34 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 8796 - patron cards not starting on designated card (3.15 KB, patch)
2015-04-09 16:42 UTC, Marc Véron
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-09-20 11:59:29 UTC
When I put a number in "Enter starting card number" I am expecting it to
start printing cards in that position the way it does in the label creator.
However it always starts in the first position.

I have tested and confirmed this in 3.8.4 and Master (as of this morning).
Comment 1 Marc Véron 2012-09-24 20:06:06 UTC Comment hidden (obsolete)
Comment 2 Marc Véron 2012-09-24 20:25:33 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2012-09-28 12:45:18 UTC Comment hidden (obsolete)
Comment 4 Mason James 2012-10-03 22:09:07 UTC
(In reply to comment #3)
> Created attachment 12573 [details] [review]
> [SIGNED-OFF] Bug 8796 - patron cards not starting on designated card
> 
> Better wording for the meaning of 'Position' to prevent mistakes on
> behaviour.
> 
> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

trivial patch, passing QA...
Comment 5 Paul Poulain 2012-10-05 15:16:36 UTC
Patch pushed to master (severity lowered, it's not major !)
Comment 6 Chris Cormack 2012-10-06 07:08:34 UTC
Pushed to 3.8.x, will be in 3.8.6
Comment 7 Nicole C. Engard 2013-04-15 12:52:26 UTC
This is an issue in the 3.10.x (and probably master) branch
Comment 8 Nicole C. Engard 2014-05-12 13:01:28 UTC
I reopened this last year and then veron@veron.ch  closed it without comment.  This is still an issue in master as of this morning. I tested it.

Nicole
Comment 9 Marc Véron 2014-05-12 14:57:21 UTC
Sorry, I mistaked. After patch 2012-09-28 12:45 UTC was pushed for 3.8.6 (signed off by Kyle M Hall), the behavior was as expected (Better wording for the meaning of 'Position' to prevent mistakes on behaviour).

It seems that meanwhile the behaviour changed. On current master, printing a batch of cards seems always to start on the first (top left) position (and not as shown in attachment 1).

Should the version be set to "Current master" (instead of 3.8) ?
Comment 10 Heinrich Hartl 2015-03-27 21:49:45 UTC
The bug is still existing in 3.18.4. Printing in the created .pdf starts irrespective of input in position 1 of the label sheet/template.
The bug is effectively preventing the use of patron label creator. So I suggest it to be given higher priority!

Moreover the documentation of the patron card creator in the manual is incomplete. In 
http://translate.koha-community.org/manual/3.18/en/html-desktop \ /#patroncardcreator 
Chapter 3.1.6.4. Batches seems to be truncated / incomplete.

The text displayed in the 3.18.4 export popup is 
Enter starting card number
and seems not to be consistent with attachment [SIGNED-OFF] Bug 8796...  The user is still left without clear idea what this value means. Why not use a text similar to "Start printing in template-position" []
Comment 11 Marc Véron 2015-03-29 09:33:59 UTC
Comment on attachment 12573 [details] [review]
[SIGNED-OFF] Bug 8796 - patron cards not starting on designated card

Applying: Bug 8796 - patron cards not starting on designated card
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
No changes -- Patch already applied.

Obsoleted this patch.
Comment 12 Marc Véron 2015-03-29 09:57:13 UTC Comment hidden (obsolete)
Comment 13 Josef Moravec 2015-03-30 06:10:33 UTC Comment hidden (obsolete)
Comment 14 Katrin Fischer 2015-04-06 09:33:16 UTC Comment hidden (obsolete)
Comment 15 Tomás Cohen Arazi 2015-04-09 13:40:58 UTC
Please rebase so I push it.
Comment 16 Marc Véron 2015-04-09 16:34:28 UTC Comment hidden (obsolete)
Comment 17 Marc Véron 2015-04-09 16:36:11 UTC
Comment on attachment 37628 [details] [review]
Bug 8796 - patron cards not starting on designated card

Did a mistake while rebasing. Obsoleted.
Comment 18 Marc Véron 2015-04-09 16:42:20 UTC
Created attachment 37629 [details] [review]
Bug 8796 - patron cards not starting on designated card

The patron cards always printed from position 1 on the print form, because patroncards/create-pdf.pl expected start_label as parameter and got star_card instead.

To verify and test:
1)
Go to Home > Tools >Patron card creator >Manage batches
2)
Select a batch anc click "Export"

3)
Set "Enter starting card number" e.g. to 5
4)
Export
5)
Download PDF and view it

Result: The first card is always printed on position 1 (top left) instead of position 5.

Apply patch
Repeat steps above
Step 3) should now read "Enter starting card position"

Result after step 5)
The first card ist printed at the correct position on the printing form.

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>

Works as expected

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Rebased for current master and tested. /MV
Comment 19 Marc Véron 2015-04-09 16:45:24 UTC
I hope it's OK to put it back to Passed QA after rebase (1 line).
Comment 20 Tomás Cohen Arazi 2015-04-09 17:13:52 UTC
(In reply to Marc Véron from comment #19)
> I hope it's OK to put it back to Passed QA after rebase (1 line).

It is!
Comment 21 Tomás Cohen Arazi 2015-04-09 18:00:21 UTC
Patch pushed to master.

Thanks Marc!
Comment 22 Chris Cormack 2015-04-20 10:07:32 UTC
String changes, held for 3.18.7
Comment 23 Chris Cormack 2015-04-29 21:33:03 UTC
Theres a conflict in patroncards/create-pdf.pdf .. please rebase on 3.18.x if you want it in 3.18.7