Bug 8882 - Hourly circ doesn't work with the calendar
Summary: Hourly circ doesn't work with the calendar
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low blocker (vote)
Target Milestone: Oldversions
Assignee: Bugs List
QA Contact:
URL:
Whiteboard:
Keywords:
: 9041 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-05 17:10 UTC by Elliott Davis
Modified: 2018-12-16 19:32 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot of pop-up asking for date due (127.99 KB, image/tiff)
2012-10-17 18:38 UTC, Melia Meggs
Details
Bug 8882 - Hourly circ doesn't work with the calendar (720 bytes, patch)
2012-11-14 13:10 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Elliott Davis 2012-10-05 17:10:50 UTC
Steps to reproduce:

1) Set usedaysmode to either push the due date or don't fine based on the calendar.
2) attempt to check out an hourly circ item
3) you should receive a pop-up asking for a date due since the due date is about to be in the past.
4) after agreeing to checkout, you item is now overdue since it was due at 00:00 the day you checked it out

I can provide screenshots if needed to illustrate the problem.
Comment 1 Melia Meggs 2012-10-05 19:52:41 UTC
This worked in 3.8.3 but is broken in 3.8.4 and 3.8.5, I believe.
Comment 2 Melia Meggs 2012-10-17 18:38:35 UTC
Created attachment 12889 [details]
screenshot of pop-up asking for date due

Here's a screenshot of what happens when you try to check out an hourly item.  As Elliott said, you get a pop-up asking you to confirm the due date.  The pop-up has a blank due date box.  If you click on Yes, it gives a due date of today 00:00, which means your item is instantly overdue, instead of giving a due date of one hour from now (or whatever your hourly circ rule says).

As a result, you can't circulate hourly.
Comment 3 Kyle M Hall 2012-11-14 13:10:35 UTC
Created attachment 13444 [details] [review]
Bug 8882 - Hourly circ doesn't work with the calendar
Comment 4 Kyle M Hall 2012-11-14 13:14:14 UTC
I should note that this is fixed in both 3.8.x and master. So this bug report should probably be marked as RESOLVED / FIXED.
Comment 5 Kyle M Hall 2012-11-14 13:17:06 UTC
*** Bug 9041 has been marked as a duplicate of this bug. ***