Bug 8936 - Search RSS feeds does not show there items when subscribing in Firefox
Summary: Search RSS feeds does not show there items when subscribing in Firefox
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Fridolin SOMERS
QA Contact: Paul Poulain
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 08:51 UTC by Fridolin SOMERS
Modified: 2013-12-05 20:01 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.66 KB, patch)
2012-10-17 08:55 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 8935 - transport cost matrix could be prettier (4.46 KB, patch)
2012-10-17 16:56 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 8936: Search RSS feeds does not show there items when subscribing in Firefox (1.75 KB, patch)
2012-10-29 18:09 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2012-10-17 08:51:53 UTC
In OPAC and with Firefox, after a search, click on RSS icon.
When language is not english (translated templates), the subscribing page does not show items.
When adding RSS feeds to a reader, the items are well displayed.

Small bug but most readers will think the RSS feeds does not work.

'RequestOnOpac' syspref must be off.
Comment 1 Fridolin SOMERS 2012-10-17 08:55:13 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2012-10-17 16:56:29 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2012-10-17 17:06:30 UTC
Sorry for the incorrect attachment, git bz typo!
Comment 4 Kyle M Hall 2012-10-19 12:30:43 UTC
This isn't working for me, I think.

In English before and after applying the patch, I get something like this.

**** EXAMPLE ****
Search for 'kw,wrdl: learn'
          Search results for 'kw,wrdl: learn' at
        
      
      Learning Ruby /By Fitzgerald, Michael,. 
	   Sebastopol, Calif. : O'Reilly, 2007
                        . xv, 238 p. :
                        , "The language that powers Rails."--Cover.
                         24 cm.. 
                         9780596529864 (pbk.) | 0596529864 (pbk.)
       

Place Hold on Learning Ruby /Learning Perl /By Schwartz, Randal L.. 
	   Beijing ; | Sebastopol : O'Reilly, 2011
                        . xxi, 363 p. :
                        , Includes index.
                         24 cm.. 
                         9781449303587
       

Place Hold on Learning Perl /
***** /EXAMPLE ****

Before and after the patch when switched to French, I get this:

***** EXAMPLE *****
Search for 'kw,wrdl: learn'
Search results for 'kw,wrdl: learn' at
              
Learning Ruby /

Learning Perl /
***** /EXAMPLE *****

The results are a be mangled from copying and pasting, but basically, I'm not seeing any changes.

If I am testing incorrectly, please let me know and post a test plan!
Comment 5 Fridolin SOMERS 2012-10-19 12:50:13 UTC
test plan :
-----------

The problem is more important in translated OPAC.
But still, in 'en' you can still reproduce the bug :

- Set RequestOnOpac syspref to "don't allow"
- Perform a search on OPAC
- Click on RSS feed button (next to result count)
You get a view of RSS feeds.
- Look at page source code : Ctrl+U
You can see that in each <description> tag, there is a opening <p> tag with no closing </p> tag : 
example :
<description><![CDATA[
<img src="http://images.amazon.com/images/P/2744102202.01.TZZZZZZZ.jpg" alt="" />

	   <p>By Maurizio FORTE. 
	   France loisirs 1996
                    
                        . 295 p.
                        , Cet ouvrage nous présente une nouvelle vision de l'intervention virtuelle,ici c'est un hymne à la gloire archéologique.
                         30 cm. 
                         2744102202 </p><p>

						]]></description>

I hope it helps reproduce.
Comment 6 Paul Poulain 2012-10-28 18:44:59 UTC
Fridolyn, it seems you provided the patch and switched to signed-off yourself. Am I missing something ? Kyle, could you test & reproduce ?
Comment 7 Fridolin SOMERS 2012-10-29 09:36:57 UTC
(In reply to comment #6)
> Fridolyn, it seems you provided the patch and switched to signed-off
> yourself. Am I missing something ? Kyle, could you test & reproduce ?

Your right, patch needs sign-off
Comment 8 Kyle M Hall 2012-10-29 18:09:31 UTC
Created attachment 13103 [details] [review]
Bug 8936: Search RSS feeds does not show there items when subscribing in Firefox

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 9 Paul Poulain 2012-10-30 17:25:25 UTC
QA comment :
 * small patch that fixes html error when requetOnOpac is off
 * passes koha-qa.pl

passed QA
Comment 10 Paul Poulain 2012-10-30 17:25:36 UTC
Patch pushed to master
Comment 11 Chris Cormack 2012-10-30 22:17:50 UTC
Pushed to 3.8.x, will be in 3.8.7
Comment 12 Liz Rea 2012-11-28 01:51:30 UTC
Pushed to 3.6.x will be in 3.6.11.