Bug 8943 - Add table sorting to labels
Summary: Add table sorting to labels
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-18 14:06 UTC by Kyle M Hall
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8943 - Add table sorting to labels (4.50 KB, patch)
2012-10-18 14:06 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 8943 - Add table sorting to labels (4.50 KB, patch)
2012-10-31 16:52 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export. (2.51 KB, patch)
2012-11-01 16:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
[Signed off] Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export. (2.53 KB, patch)
2012-11-08 01:01 UTC, Melia Meggs
Details | Diff | Splinter Review
[Signed off] Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export. (2.59 KB, patch)
2013-03-08 21:04 UTC, Melia Meggs
Details | Diff | Splinter Review
[Signed off] Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export. (2.59 KB, patch)
2013-03-08 21:43 UTC, Melia Meggs
Details | Diff | Splinter Review
[Signed off] Bug 8943 - Add table sorting to labels (4.58 KB, patch)
2013-03-08 21:56 UTC, Melia Meggs
Details | Diff | Splinter Review
[PASSED QA] Bug 8943 - Add table sorting to labels (4.63 KB, patch)
2013-03-31 08:42 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export. (2.68 KB, patch)
2013-03-31 08:42 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2012-10-18 14:06:33 UTC
Currently, the label-manage.pl has a table that is sorted by the label id ( i.e. by the order in which the rows were inserted into the database ). This sorting is not very useful. It would be better to allow sorting, and to sort by name by default.
Comment 1 Kyle M Hall 2012-10-18 14:06:50 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2012-10-31 16:52:09 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2012-11-01 16:46:31 UTC Comment hidden (obsolete)
Comment 4 Melia Meggs 2012-11-08 01:01:48 UTC Comment hidden (obsolete)
Comment 5 Melia Meggs 2012-11-08 01:04:06 UTC
I applied these patches and tested.  I can confirm that the label layouts, templates and profiles are now sorted by the "name" column alphabetically by default.  The sort buttons on the various columns work correctly.  The pulldown menu when you go to export a batch is also correctly sorted alphabetically by default.

The only thing I thought was weird (not necessarily wrong, but kind of weird) was that the batches appear to be sorted by "item count" by default.  Is that useful?  I would think batches might be the one place where keeping them in order of batch id might be better, although you can, of course, easily use the column sort to put them in that order if you want them that way.

I will add my signoff since these patches apply and work as advertised, but this also requires non-ByWater testing and signoff.  I hope the next tester will consider my question above about batch id vs. item count and voice an opinion on what would be more useful.

Thanks,

Melia
Comment 6 Nora Blake 2013-03-08 20:51:55 UTC
I have tested this and it works the way I would expect it to.

Nora Blake
Comment 7 Melia Meggs 2013-03-08 21:04:19 UTC Comment hidden (obsolete)
Comment 8 Melia Meggs 2013-03-08 21:27:43 UTC
Hhmm... Well, I intended to sign off on both the original patch and the follow up patch for both Nora and me, but I can only seem to get the sign off onto the follow up patch.  I am not succeeding with git-bz on this Friday afternoon.  I'm sorry!  Please consider them both signed off.
Comment 9 Melia Meggs 2013-03-08 21:43:46 UTC Comment hidden (obsolete)
Comment 10 Melia Meggs 2013-03-08 21:56:00 UTC Comment hidden (obsolete)
Comment 11 Katrin Fischer 2013-03-31 08:42:31 UTC
Created attachment 17079 [details] [review]
[PASSED QA] Bug 8943 - Add table sorting to labels

Signed-off-by: Melia Meggs <melia@bywatersolutions.com>
Signed-off by: Nora Blake <nblake@masslibsystem.org>

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 12 Katrin Fischer 2013-03-31 08:42:43 UTC
Created attachment 17080 [details] [review]
[PASSED QA] Bug 8943 - Add table sorting to labels - Followup - Sort pulldowns in batch export.

Signed-off-by: Melia Meggs <melia@bywatersolutions.com>
Signed-off-by: Nora Blake <nblake@masslibsystem.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
All tests and QA script pass.
Comment 13 Jared Camins-Esakov 2013-03-31 12:34:03 UTC
This patch has been pushed to master.