Bug 9110 - GetAuthorizedHeading Can't call method "field" on an undefined
Summary: GetAuthorizedHeading Can't call method "field" on an undefined
Status: RESOLVED DUPLICATE of bug 10066
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 03:55 UTC by wajasu
Modified: 2014-09-01 12:06 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wajasu 2012-11-20 03:55:55 UTC
I deleted my auth_header records;

When runnong misc/link_bibs_to_authorities.pl
With LinkerRelink = Do   I get:

GetAuthorizedheading Can't call method "field" on an undefined value at /home/koha/kohaclone/C4/AuthoritiesMarc.pm line 1191

In my case, I deleted the auth_header records, since I wanted to regenerate them.  They had lots of dups since I was upgrading from a 3.0 version to (master pre-3.10).

I reindexed the bibs and auths, but since I shouldn't find any auths, and though my bibs might have dangling $9 links, there might need to be a check that $record->field is viable.


other settings:
CatalogModuleRelink  Do
LinkerKeepStale = do not
LinkerModule - default
AutoCreateAuthorities  - either setting
BiblioAddsAuthorities - allow
UseAuthoritiesForTracings -either setting

Fuzzy not enabled.
Comment 1 Katrin Fischer 2014-09-01 12:06:20 UTC

*** This bug has been marked as a duplicate of bug 10066 ***