Bug 9245 - Visual Bug under fines tab
Summary: Visual Bug under fines tab
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Viktor Sarge
QA Contact: Jonathan Druart
URL:
Whiteboard:
Keywords:
: 12447 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-07 17:13 UTC by Jesse Maseto
Modified: 2015-06-04 23:30 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Fine Tab (48.39 KB, application/pdf)
2012-12-07 17:13 UTC, Jesse Maseto
Details
Fines tab (18.89 KB, image/png)
2012-12-07 17:16 UTC, Owen Leonard
Details
9245 Fixes visual bux with fines tab not highlighting (1.95 KB, patch)
2014-06-16 11:28 UTC, Viktor Sarge
Details | Diff | Splinter Review
[SIGNED-OFF] 9245 Fixes visual bux with fines tab not highlighting (2.04 KB, patch)
2014-06-16 16:07 UTC, Nicole C. Engard
Details | Diff | Splinter Review
9245 Fixes visual bux with fines tab not highlighting (2.07 KB, patch)
2014-06-19 09:25 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Maseto 2012-12-07 17:13:27 UTC Comment hidden (obsolete)
Comment 1 Owen Leonard 2012-12-07 17:16:54 UTC
Created attachment 13948 [details]
Fines tab
Comment 2 Nicole C. Engard 2014-06-10 19:41:07 UTC
This is still an issue in master.
Comment 3 Viktor Sarge 2014-06-16 11:28:11 UTC Comment hidden (obsolete)
Comment 4 Nicole C. Engard 2014-06-16 16:07:38 UTC Comment hidden (obsolete)
Comment 5 Christopher Brannon 2014-06-18 22:11:22 UTC
Viktor,
looks like we have the same issue we had on bug 12332.  Please start the commit message of your patches by "Bug XXXXX". Otherwise the sandboxes cannot signoff them.  Thanks.

Christopher
Comment 6 Viktor Sarge 2014-06-19 06:01:32 UTC
(In reply to Christopher Brannon from comment #5)
> Viktor,
> looks like we have the same issue we had on bug 12332.  Please start the
> commit message of your patches by "Bug XXXXX". Otherwise the sandboxes
> cannot signoff them.  Thanks.
> 
> Christopher

Yes I missed formatting the first line with "Bug XXXX" in my first five patches. Would I mess up anything if I resubmit those that are not yet signed off with a correct first line?
Comment 7 Jonathan Druart 2014-06-19 09:25:57 UTC
Created attachment 28981 [details] [review]
9245 Fixes visual bux with fines tab not highlighting

This patch makes shure that mancredit.pl, maninvoice.pl and pay.pl passes the value "finesview=1" that makes the tab active.

Test plan:
1) Go to a library user and the fines tab. Note that the "Fines" tab loses it's highlight when you click "Pay fines", "Create manual invoice" and "Create manual credit".
2) Install the patch.
3) Redo the first step and make shure that the left menu tab "Fines" is now highlighted all the time.

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 8 Jonathan Druart 2014-06-19 09:26:41 UTC
I developed exactly the same fix yesterday on bug 12447.
Comment 9 Jonathan Druart 2014-06-19 09:26:56 UTC
*** Bug 12447 has been marked as a duplicate of this bug. ***
Comment 10 Tomás Cohen Arazi 2014-07-07 18:32:41 UTC
Patch pushed to master.

Thanks Viktor!
Comment 11 Galen Charlton 2014-07-23 21:35:39 UTC
Pushed to 3.16.x for inclusion in 3.16.2.