Bug 9265 - Switch to HTML5 doctype in OPAC and staff client
Summary: Switch to HTML5 doctype in OPAC and staff client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-11 17:32 UTC by Owen Leonard
Modified: 2014-05-26 21:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 9265 - Switch to HTML5 doctype in OPAC and staff client (39.85 KB, patch)
2012-12-12 17:56 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9265 - Switch to HTML5 doctype in OPAC and staff client (40.02 KB, patch)
2012-12-13 14:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 9265 - Switch to HTML5 doctype in OPAC and staff client (40.09 KB, patch)
2013-01-29 19:31 UTC, Mason James
Details | Diff | Splinter Review
Bug 9265 - Switch to HTML5 doctype in OPAC and staff client (40.13 KB, patch)
2013-01-29 19:32 UTC, Mason James
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2012-12-11 17:32:51 UTC
With some patches using HTML5 already in the pipeline (Bug 8377) and some useful features already showing broad support (http://caniuse.com/#feat=form-validation, http://caniuse.com/#feat=input-placeholder), I think it's time to show our intention to start using these new features by updating Koha's doctype to an HTML5 one:

<!DOCTYPE html>

I propose that we do not change our HTML markup guidelines which require that tags be closed, attributes be quoted, etc.
Comment 1 Mirko Tietgen 2012-12-11 17:37:33 UTC
+1
Comment 2 Owen Leonard 2012-12-12 17:56:59 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2012-12-13 14:30:04 UTC Comment hidden (obsolete)
Comment 4 Mason James 2013-01-29 19:31:32 UTC Comment hidden (obsolete)
Comment 5 Mason James 2013-01-29 19:32:12 UTC
Created attachment 14926 [details] [review]
Bug 9265 - Switch to HTML5 doctype in OPAC and staff client

This patch replaces the XHTML DOCTYPE with an HTML5 one. The HTML5
validator seems to be significantly different than the XHTML one,
so I'm seeing lots of new errors. This patch includes corrections
for one: Deprecation of the "language" attribute of <script>
tags.

To test, view pages in the OPAC and staff client. They should
appear as normal. Numerous validation follow-ups will be required,
but I suggest these be handled incrementally.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
test on some intranet pages and I found no regression. (chromium and
firefox).
The w3c page about the doctype: http://www.w3.org/TR/html5-diff/#doctype

Signed-off-by: Mason James <mtj@kohaaloha.com>
Comment 6 Mason James 2013-01-29 19:34:48 UTC
(In reply to comment #5)
> Created attachment 14926 [details] [review]
> Bug 9265 - Switch to HTML5 doctype in OPAC and staff client
> 
> Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
> test on some intranet pages and I found no regression. (chromium and
> firefox).
> The w3c page about the doctype: http://www.w3.org/TR/html5-diff/#doctype
> 
> Signed-off-by: Mason James <mtj@kohaaloha.com>


passing QA on this patch

tested on firefox, chrome, opera, and safari browers - with no regressions
Comment 7 Jared Camins-Esakov 2013-01-31 16:48:24 UTC
This patch has been pushed to master.

One validation error I noticed on a lot of pages in the OPAC was "Line 454, Column 47: Element script must not have attribute charset unless attribute src is also specified." (the line and column number changed, of course) However, I think this is still a good patch to get in right away.