Bug 9267 - Ubuntu 12.04 install docs broken
Summary: Ubuntu 12.04 install docs broken
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Documentation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Tomás Cohen Arazi
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-11 20:13 UTC by Tomás Cohen Arazi
Modified: 2014-05-26 21:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: String patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9267 - Ubuntu 12.04 install docs broken (3.76 KB, patch)
2012-12-11 20:18 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 9267 - Ubuntu 12.04 install docs broken (3.81 KB, patch)
2013-01-17 05:57 UTC, Galen Charlton
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2012-12-11 20:13:49 UTC
Current install instructions are broken in the (1.6) step. On amd64 architectures it breaks the whole dependency tree, pulling i386 packages.
Comment 1 Tomás Cohen Arazi 2012-12-11 20:18:31 UTC Comment hidden (obsolete)
Comment 2 Galen Charlton 2013-01-17 05:57:19 UTC
Created attachment 14654 [details] [review]
Bug 9267 - Ubuntu 12.04 install docs broken

Current install instructions are broken in the (1.6) step. On amd64
architectures it breaks the whole dependency tree, pulling i386 packages.

This patch replaces the 'dpkg --set-selections' combo and replacess some spaces
for tabs in one line.

This should be cherry-picked for other releases that have 12.04 install instructions
as the problem is related to multiarch.

Regards
To+

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Comment 3 Galen Charlton 2013-01-17 06:08:29 UTC
I did a successful Git-based, dev-mode installation on a clean 12.04 VM using the instructions as modified by the patch.

As a side note, it was necessary to use the squeeze-dev repository from debian.koha-community.org to get the right versions of libchi-perl and libdigest-jhash-perl for Koha 3.10.
Comment 4 Elliott Davis 2013-03-06 16:16:14 UTC
This patch looks like it adheres to the coding standards.  My only concern has been documented in splinter.  I am still marking it passed QA since the change doesn't appear to have changed anything.
Comment 5 Elliott Davis 2013-03-07 14:45:39 UTC
Comment on attachment 14654 [details] [review]
Bug 9267 - Ubuntu 12.04 install docs broken

Review of attachment 14654 [details] [review]:
-----------------------------------------------------------------

::: install_misc/ubuntu.12.04.packages
@@ +64,4 @@
>  libdatetime-perl			install
>  libdatetime-event-ical-perl		install
>  libdatetime-format-dateparse-perl			install
> +libdatetime-format-ical-perl		install

Why is this modified?
Comment 6 Jared Camins-Esakov 2013-03-07 14:47:48 UTC
This patch has been pushed to master.
Comment 7 Chris Cormack 2013-03-11 09:43:54 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.4 and 3.8.11
Comment 8 M. Tompsett 2013-03-23 05:00:10 UTC
Just curious why:
   git checkout -b myinstall origin
was changed to:
   git checkout -b myinstall origin/3.10.x
The latter is not "timeless" and will require continued updates.
Just a thought.
Comment 9 Tomás Cohen Arazi 2013-03-25 13:27:13 UTC
(In reply to comment #8)
> Just curious why:
>    git checkout -b myinstall origin
> was changed to:
>    git checkout -b myinstall origin/3.10.x
> The latter is not "timeless" and will require continued updates.
> Just a thought.

The problem is:
You belive installing outside packages is only for devs [1] and thus instructions on the tarball are targeted for them and (for that reason) master is what to put there.

I belive that (as with any other software package) bundled instructions are for installing the piece of software. They should be concise, and clear. I it was up to me, I'd have a different instruction files set for each Koha release. I don't put effort on maintaining that because te QA process takes so much time that this gets obsolete (this patch was targeted for the 3.10 release for instance).

[1] The fact is packages is what people uses less (just quoting chris cormack on this).  And instructions inside the tarball should be... for installing from that tarball. The git stuff should even be removed from there, as makes install instructions tl;dr and people willing to develop have other ways of getting the proper instructions and tutorials.