Bug 9314 - Remove useless code related to the type_only parameter
Summary: Remove useless code related to the type_only parameter
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 13497
Blocks: 13970
  Show dependency treegraph
 
Reported: 2012-12-21 15:38 UTC by Rolando Isidoro
Modified: 2016-12-05 21:22 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 9314: Remove useless code related to the type_only parameter (2.61 KB, patch)
2015-04-08 11:42 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9314: Remove useless code related to the type_only parameter (2.75 KB, patch)
2015-05-19 18:48 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[PASSED QA] Bug 9314: Remove useless code related to the type_only parameter (2.83 KB, patch)
2015-06-07 14:38 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Rolando Isidoro 2012-12-21 15:38:40 UTC
On the patron edit form, under the "Patron messaging preferences" there's a message stating:

"If no preferences are selected, the default preferences for the category chosen will be applied on save, otherwise your selection here is saved"

When no preferences are selected the default preferences for the chose category are not being applied on save.

As an enhancement a button could be added to reset the messaging preferences to default.
Comment 1 Owen Leonard 2012-12-21 16:29:24 UTC
Note that the message appears in a couple of situations: On patron edit, or on patron creation *if* you have your AddPatronLists preference set to "category_type." Looking at the code it looks like the message is intended to appear only upon patron add if AddPatronLists is set to "category_type." The warning is required because in that situation the patron category is not yet known. Therefore the interface reminds the user that default messaging preferences will be applied if none are chosen.
Comment 2 Jonathan Druart 2015-04-08 11:26:11 UTC
Since I suggested to remove the broken pref AddPatronLists in bug 13497, I think the better would be to simply remove the message.
Comment 3 Jonathan Druart 2015-04-08 11:42:22 UTC Comment hidden (obsolete)
Comment 4 Rolando Isidoro 2015-04-09 10:42:47 UTC
Jonathan, following your comments I can confirm that the information message is no longer displayed so this bug report is deprecated.
Comment 5 Jonathan Druart 2015-04-09 12:02:27 UTC
Rolando, without the path I submitted on comment 3, the message can longer appear.
Comment 6 Bernardo Gonzalez Kriegel 2015-05-19 18:48:30 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-06-07 14:38:52 UTC
Created attachment 39957 [details] [review]
[PASSED QA] Bug 9314: Remove useless code related to the type_only parameter

Since the pref AddPatronLists has been removed in bug 13497, the code
related to type_only and category_type in memberentry.pl is useless.

Test plan:
Confirm you don't the information message.
You can also confirm that the message was wrong and nothing was saved.

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>
Dead code removed, no errors

Think that bug description can be updated to commit message

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Tomás Cohen Arazi 2015-06-11 13:19:07 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 9 Chris Cormack 2015-06-11 20:40:31 UTC
Pushed to 3.20.x will be in 3.20.1 (shouldn't be needed for other branches)