Bug 9358 - Fixed field plugins for MARC21 should be updated for MARC21 update #15
Summary: Fixed field plugins for MARC21 should be updated for MARC21 update #15
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bernardo Gonzalez Kriegel
QA Contact: Katrin Fischer
URL:
Keywords:
: 10109 (view as bug list)
Depends on: 9357
Blocks: 6709
  Show dependency treegraph
 
Reported: 2013-01-07 16:19 UTC by Galen Charlton
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9358 - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (121.06 KB, patch)
2013-01-07 22:26 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 9358 - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (121.11 KB, patch)
2013-01-09 04:21 UTC, Galen Charlton
Details | Diff | Splinter Review
[PASSED QA] Bug 9358 - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (120.83 KB, patch)
2013-03-19 11:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 9358 - Followup - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (5.37 KB, patch)
2013-03-26 23:53 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 9358 - Followup - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (5.43 KB, patch)
2013-04-07 02:40 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 9358 - Followup - Fixed field plugins for MARC21 should be updated for MARC21 update #15 (5.54 KB, patch)
2013-04-23 05:47 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Charlton 2013-01-07 16:19:00 UTC
A few positions in the leader, 006, 007, 008 have had their list of permitted values updated in recent years:

Leader/18 - Descriptive cataloging form
c - ISBD punctuation omitted [NEW, 2010]
i - ISBD [REDEFINED, 2010]

007(maps)/04 - Physical medium
i - Plastic [NEW, 2009]
l - Vinyl [NEW, 2009]
n - Vellum [NEW, 2009]
v - Leather [NEW, 2009]
w - Parchment [NEW, 2009]

007(computer resources)/01 - Specific material designation
d - Computer disc, type unspecified [NEW, 2009]
e - Computer disc cartridge, type unspecified [NEW, 2009]
k - Computer card [NEW, 2009]

007(globe)/04 - Physical medium
i - Plastic [NEW, 2009]
l - Vinyl [NEW, 2009]
n - Vellum [NEW, 2009]
v - Leather [NEW, 2009]
w - Parchment [NEW, 2009]

007(projected medium)/01 - Specific material designation
f - Other type of filmstrip [RENAMED, 2009]

007(microform)/01 - Specific material designation
h - Microfilm slip [NEW, 2009]
j - Microfilm roll [NEW, 2009]

007(non projected graphic)/01 - Specific material designation
a - Activity card [NEW, 2009]
k - Poster [NEW, 2009]
p - Postcard [NEW, 2009]
q - Icon [NEW, 2009]
r - Radiograph [NEW, 2009]
s - Study print [NEW, 2009]
v - Photograph, type unspecified [NEW, 2009]

007(non projected graphic)/04 - Primary support material
i - Plastic [NEW, 2009]
l - Vinyl [NEW, 2009]
n - Vellum [NEW, 2009]
v - Leather [NEW, 2009]
w - Parchment [NEW, 2009]

007(non projected graphic)/05 - Secondary support material
i - Plastic [NEW, 2009]
l - Vinyl [NEW, 2009]
n - Vellum [NEW, 2009]
v - Leather [NEW, 2009]
w - Parchment [NEW, 2009]

007(motion picture)/01 - Specific material designation [NEW, 2009]
o - Film roll [NEW, 2009]

007(videorecording)/04 - Videorecording format
s - Blu-ray disc [NEW, 2008]

008(books)/23 - Form of item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(computer files)/23 - Form of item [NEW, 2010]
Prior to the definition of this element, the byte was undefined and contained a blank (#) or a fill character (|).
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(maps)/29 - Form of item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(continuing resources)/22 - Form of original item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(continuing resources)/23 - Form of item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(visual materials)/29 - Form of item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

008(mixed materials)/23 - Form of item
o - Online [NEW, 2010]
q - Direct electronic [NEW, 2010]

The fixed field plugins for MARC21 should be updated to match these updates.

As a reminder, the 006 fixed field positions follow the 008 for the matching format, so changes in marc21_field_008.xml will also need to be made to marc21_field_006.xml.
Comment 1 Bernardo Gonzalez Kriegel 2013-01-07 22:26:20 UTC Comment hidden (obsolete)
Comment 2 Galen Charlton 2013-01-09 04:21:32 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-03-19 11:20:48 UTC
Created attachment 16369 [details] [review]
[PASSED QA] Bug 9358 - Fixed field plugins for MARC21 should be updated for MARC21 update #15

This patch, together with 9357, fix plugins for leader, 006, 007 and 008 MARC21 fields

Leader18 c and i is fixed on Bug 9357

Added missing/renamed fields on 007

Options 'o' and 'q' already present on 006 and 008,
fixing spaces and removing unnecessary descriptions.

To test:
1) Catalog/edit a record
2) On 007 value builder, check missing values
   on 008, BKS, check for example 33- Literary form,
   i- Letters has a description
3) Apply the patch
4) Clean your browser cache
5) On 007 value builder, new values are present
   On 008/6 descriptions are absent

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Works as described.
Comment 4 Jared Camins-Esakov 2013-03-20 03:11:18 UTC
I would be willing to push this as a partial fix, but it does not update all the fixed field plugins for MARC21 update #5. 008/20 for music should have an additional value 'k' for vocal scores (and there may be other gaps). However, I'm setting this to "In Discussion" for now, pending feedback from Bernardo about whether he wants to do a follow-up before I push it, or open another bug for the last missing values.
Comment 5 Bernardo Gonzalez Kriegel 2013-03-20 20:21:54 UTC
(In reply to comment #4)
> I would be willing to push this as a partial fix, but it does not update all
> the fixed field plugins for MARC21 update #5. 008/20 for music should have
> an additional value 'k' for vocal scores (and there may be other gaps).
> However, I'm setting this to "In Discussion" for now, pending feedback from
> Bernardo about whether he wants to do a follow-up before I push it, or open
> another bug for the last missing values.

I'll do a follow-up. Better to fix it now.
Comment 6 Bernardo Gonzalez Kriegel 2013-03-26 23:53:52 UTC Comment hidden (obsolete)
Comment 7 Bernardo Gonzalez Kriegel 2013-03-26 23:55:21 UTC
Switch to Needs Signof. Small followup.
Comment 8 Chris Cormack 2013-04-07 02:40:19 UTC Comment hidden (obsolete)
Comment 9 Katrin Fischer 2013-04-23 05:47:14 UTC
Created attachment 17605 [details] [review]
[PASSED QA] Bug 9358 - Followup - Fixed field plugins for MARC21 should be updated for MARC21 update #15

This little patch adds a few values and descriptions to complete
value builder for marc21 008.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Follow-up works as described.
XML change only.
Comment 10 Jared Camins-Esakov 2013-04-23 13:05:06 UTC
This patch has been pushed to master and 3.12.x. Thanks for filling in the gaps.
Comment 11 Bernardo Gonzalez Kriegel 2013-04-23 13:59:58 UTC
Well, right now I have mixed feelings about this :-)

I'm working on a yet unnamed patch to change the structure 
of these files (xml for 006 and 008).

The purpose is move attributes to elements, so to make these files translatable.

In that way standard tools could be used to extract all strings.
I'll report (in other bug) when done.
Comment 12 Katrin Fischer 2013-04-23 14:10:30 UTC
Hi Bernardo,
I would really love to see that long standing bug fixed.
Comment 13 Nicole C. Engard 2013-04-24 20:39:33 UTC
*** Bug 10109 has been marked as a duplicate of this bug. ***
Comment 14 Chris Cormack 2013-05-09 19:35:32 UTC
Pushed to 3.10.x will be in 3.10.6
Comment 15 Chris Hall 2013-06-06 09:27:21 UTC
Both patches have been pushed to 3.8.x, will be in 3.8.14