Bug 9375 - Logging in with LDAP creates duplicate users
Summary: Logging in with LDAP creates duplicate users
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Authentication (show other bugs)
Version: 3.8
Hardware: All All
: P1 - high critical (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 22:12 UTC by Liz Rea
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2013-01-09 22:12:21 UTC
Bug noted in 3.8, probably exists in master as well.

To replicate:

Create a "native" koha user with the same username/password as your LDAP user.
Log in with LDAP - a duplicate user should be created with the mapped fields in the borrower account.

I think this is not working as intended - my thought is that if a user exists in Koha, and the user/password are identical, one of two things should happen:

Either Koha should recognize that this user exists and ask the user if they want to populate the existing account with the data from LDAP, or Koha should recognize that this user exists and simply log in, leaving the member account alone and inserting no data.

Thoughts?
Comment 1 Liz Rea 2013-01-10 02:23:54 UTC
Also try this with the username the same, but the password different - further investigation reveals that it might be that instead.
Comment 2 Dobrica Pavlinusic 2013-05-27 10:15:42 UTC
I changed priority of this bug because it's critical for installation with LDAP login (like us). I will try to fix it in next few days and submit report because it hurts us pretty badly.
Comment 3 Dobrica Pavlinusic 2013-05-31 12:41:23 UTC
I can't reproduce this bug. I have created user in Koha with same login as LDAP user, but different password. I can login with both local password and ldap password and don't see any duplication of users (this is sub-optimal, but I'm not using replicate in my ldap config so this is expected behaviour).

Having said all this, I do have duplicate users in our production installation which means that bug is valid, I just can't reproduce it.
Comment 4 Dobrica Pavlinusic 2013-05-31 12:51:30 UTC
Forgot to mention, I tested 3.11.00.202 and 3.13.00.006 (current master) using OPAC login (but intranet uses same code, so it shouldn't matter)
Comment 5 Katrin Fischer 2013-09-30 21:39:59 UTC
This does sound bad - any progress on replicating and squashing the bug?
Comment 6 Dobrica Pavlinusic 2014-03-12 10:05:55 UTC
bus 8148 addresses logging with both passwords, but I still can't reproduce duplication. Should we say it was fixed somehow since it was reported and close this bug?
Comment 7 Katrin Fischer 2014-03-12 10:19:45 UTC
If you can't reproduce it, you can mark it RESOLVED - WORKSFORME, but of course the bug can be reopened, if someone else manages to.