Bug 9382 - Bold necessary permissions for staff client access.
Summary: Bold necessary permissions for staff client access.
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 21:06 UTC by Liz Rea
Modified: 2014-05-26 21:04 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9382 - updating permission labels (8.54 KB, patch)
2013-01-22 20:09 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 9382 - updating permission labels (8.81 KB, patch)
2013-01-22 21:21 UTC, Liz Rea
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9382 - updating permission labels (9.00 KB, patch)
2013-01-28 19:16 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9382 - updating permission labels (9.15 KB, patch)
2013-01-29 09:17 UTC, Elliott Davis
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2013-01-13 21:06:14 UTC
The View Catalogue permission is required for staff client access, but neither the description nor the name of it indicate that it is required.

I propose changing the description and making it bold to indicate it's importance to staff client access.
Comment 1 Liz Rea 2013-01-22 20:09:11 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2013-01-22 21:02:16 UTC
I see a few differences between the start-from-scratch database and the updated-existing database versions:

Flag 2, "catalogue":

New db: "Staff access, allows viewing of catalogue in staff client.)"
Updated db: Staff access, allows viewing of catalogue in staff client."

(^^ extra ')' in new db)

Flag 3, "parameters":

New db: "Set Koha system parameters."
Updated db: "Manage Koha system settings (Administration panel)"

Flag 12, "management":

New db: "Manage Koha system settings (Administration panel)"
Updated db: "Set library management parameters (deprecated)"

And by the way, unrelated to this patch:

tools:edit_patrons

New db: "Perform batch modification of patrons"
Updated db: "Perform batch modifivation of patrons"
Comment 3 Liz Rea 2013-01-22 21:07:20 UTC
Ah thanks - will fix those things. :)
Comment 4 Liz Rea 2013-01-22 21:21:12 UTC Comment hidden (obsolete)
Comment 5 Owen Leonard 2013-01-28 19:16:06 UTC Comment hidden (obsolete)
Comment 6 Elliott Davis 2013-01-29 09:17:48 UTC
Created attachment 14911 [details] [review]
Bug 9382 - updating permission labels

first, replicate:
go to More -> permissions on any user. Notice that it says various things "privileges, flags, permissions" they are interchangeable and inconsistent.
also note that some of the permissions are nonsensical and/or not descriptive enough, or not using canonical terminology (borrowers instead of patrons, for example)

To test:
interface consistency changes

-> means "turns into"

- page title - privileges -> permissions
- breadcrumbs - privileges -> permissions
- headings - privileges -> permissions
- "set flags" button -> save

Permissions that have changed description:

- Catalogue changes to "Required for staff login" in bold (this was the original impetus for this boatload of changes)
- reports
- editauthorities
- management
- serials
- updatecharges
- circulate
- parameters
- borrowers
- tools
- staffaccess
- edit_patrons (only on updatedb, not on new db)

- Read through and make sure there are no typos, and that the descriptions seem to jive with what privileges the permission gives the user. Suggestions are, in fact, welcome.

- If you are feeling ambitious, go ahead and create a new, clean database and check the wording there as well - it should match what has been done in the db update.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Tested both with existing database and new database

Signed-off-by: Elliott Davis <elliott@bywatersolions.com>
Tested with existing database.  Introduces no new mysql-isms.
Kudos for adding that syspref in bold, that got me when I first started with Koha
Comment 7 Jared Camins-Esakov 2013-01-31 16:34:25 UTC
This patch has been pushed to master.

There are still capitalization issues in the permissions, but the screen is much better with this patch.
Comment 8 Chris Cormack 2013-02-03 02:58:48 UTC
Pushed to 3.10.x will be in 3.10.3
Comment 9 Katrin Fischer 2013-02-12 21:17:37 UTC
Um, hate to point it out - but this untranslates existing translated permissions for non-English installations... could we add a condition here please?
Comment 10 Katrin Fischer 2013-02-12 21:32:10 UTC
Apart from that I think staffaccess does not do what the description says, as that is what permissions does:

 INSERT INTO `userflags` VALUES(5,'permissions','Set user permissions',0);

+INSERT INTO `userflags` VALUES(17,'staffaccess','Allow staff members to modify permissions for other staff members',0);

From looking at the code and from what we experienced with one of our libraries I think the permission is actually about changing other staff account details (like passwords, usernames, etc.)
Comment 11 Chris Cormack 2013-02-13 02:22:28 UTC
(In reply to comment #9)
> Um, hate to point it out - but this untranslates existing translated
> permissions for non-English installations... could we add a condition here
> please?

Sorry Katrin, not sure what you mean here? What kind of condition?
Comment 12 Katrin Fischer 2013-02-13 06:30:12 UTC
For example we could check for English strings in the permissions description - so German and other translated permissions would not be harmed by this patch.
Comment 13 Katrin Fischer 2013-02-13 07:43:30 UTC
To be more clear - I am talking about the updatedatabase.pl part of this patch :)
Comment 14 Katrin Fischer 2013-02-13 12:04:18 UTC
Bug should not be reopened because it's already been pushed, so I think another patch has to go on a new bug? Should I file one?
Comment 15 Derryn 2013-02-24 11:54:17 UTC
When I updated from 3.10.00 to 3.10.03 the web installer throws this:

updatedatabase.pl: Undefined subroutine &main::CheckVersion called at /usr/share/koha/intranet/cgi-bin/installer/data/mysql/updatedatabase.pl line 6092.

That particular line was added by this patch:

if ( CheckVersion($DBversion) ) {

Upon further investigation, there is indeed no 'CheckVersion' subroutine that I could find.
Comment 16 Chris Cormack 2013-02-24 17:41:53 UTC
Fixed and new tarball pushed, thanks for the catch.
Comment 17 Manos PETRIDIS 2013-04-06 20:16:56 UTC
Could this "CheckVersion" error have crept into v3.08.11 as well? If so, please check bug #9962 for details.