Bug 9414 - Fix sample letters for German and Norwegian
Summary: Fix sample letters for German and Norwegian
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Target Milestone: ---
Assignee: Magnus Enger
QA Contact: Marcel de Rooy
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-17 07:31 UTC by Katrin Fischer
Modified: 2014-05-26 21:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9414 - Fix sample letters for German and Norwegian (15.47 KB, patch)
2013-03-18 14:44 UTC, Magnus Enger
Details | Diff | Splinter Review
Bug 9414 - Fix sample letters for German and Norwegian (15.52 KB, patch)
2013-04-08 08:25 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 9414 - Fix sample letters for German and Norwegian (15.61 KB, patch)
2013-04-11 11:48 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-01-17 07:31:43 UTC
The new renewal notice in the sample SQL file for the web installer should be translated to German.
Comment 1 Magnus Enger 2013-03-18 09:51:17 UTC
I'll do a patch for German and Norwegian together.
Comment 2 Magnus Enger 2013-03-18 14:44:24 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2013-04-08 08:25:03 UTC Comment hidden (obsolete)
Comment 4 Marcel de Rooy 2013-04-11 11:48:00 UTC
Created attachment 17367 [details] [review]
Bug 9414 - Fix sample letters for German and Norwegian

Some letters were missing or not translated in the German and
Norwegian data for the webinstaller. This patch adds them.

German
- RENEWAL (present, but not translated)
- OPAC_REG_VERIFY (missing)

Norwegian
- RENEWAL (present, but not translated)
- ISSUESLIP (missing)
- ISSUEQSLIP (missing)
- RESERVESLIP (missing)
- TRANSFERSLIP (missing)
- OPAC_REG_VERIFY (missing)

To test:
- Install Norwegian and German* translations
- Run through the web installer in German, making sure that
  the sample letters are selected
- Check that there are no errors in the web installer
- Check <intranet>/cgi-bin/koha/tools/letter.pl - that the
  letters look OK, and are translated
- Repeat the process for Norwegian

* = I had some problems with installing the German
translations that are in master, but now I can't reproduce
it. If you run into a problem where only some of the
subdirectories of koha-tmpl/intranet-tmpl/prog/de-DE/modules/
are cerated, try downloading and installing the 3.10 .po
files from Pootle.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 5 Marcel de Rooy 2013-04-11 11:50:12 UTC
QA Comment:
Not much to say. Looks good to me. Speak little bit German, and no Norwegian..
Ran this on a empty db. Went fine.
Assume that Katrin gave you the German translations..

Passed QA
Comment 6 Magnus Enger 2013-04-11 12:03:03 UTC
(In reply to comment #5)
> Assume that Katrin gave you the German translations..

Gah, forgot to mention that. Sorry, Katrin!
Comment 7 Katrin Fischer 2013-04-11 12:13:09 UTC
Thx for letting me mess up your patch with German :)
Comment 8 Jared Camins-Esakov 2013-04-15 12:55:12 UTC
This patch has been pushed to master and 3.12.x.
Comment 9 Chris Cormack 2013-04-26 21:36:56 UTC
Does not apply to 3.10.x please rebase if you wish it on 3.10.x