Bug 9424 - Move JavaScript out of header include
Summary: Move JavaScript out of header include
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-18 14:42 UTC by Owen Leonard
Modified: 2014-12-07 20:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9424 - Move JavaScript out of header include (7.94 KB, patch)
2013-01-18 15:37 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9424 - Move JavaScript out of header include (7.85 KB, patch)
2013-02-06 14:20 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9424 - Move JavaScript out of header include (7.86 KB, patch)
2013-02-08 18:14 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9424 [Revised] Move JavaScript out of header include (3.79 KB, patch)
2013-05-10 12:45 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9424 [Revised] Move JavaScript out of header include (3.58 KB, patch)
2013-05-23 19:54 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9424: Move JavaScript out of header include (3.56 KB, patch)
2013-05-24 16:31 UTC, Galen Charlton
Details | Diff | Splinter Review
Bug 9424: Move JavaScript out of header include (3.62 KB, patch)
2013-05-27 07:43 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2013-01-18 14:42:58 UTC
There are some JavaScript "onclicks" in header.inc which could be safely moved to staff-global.js since both are global.
Comment 1 Owen Leonard 2013-01-18 15:37:16 UTC Comment hidden (obsolete)
Comment 2 Galen Charlton 2013-02-06 04:38:53 UTC
Patch doesn't apply to master -- please rebase.
Comment 3 Owen Leonard 2013-02-06 14:20:03 UTC Comment hidden (obsolete)
Comment 4 Kyle M Hall 2013-02-08 18:14:52 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2013-03-15 15:24:13 UTC
This patch does not apply, could you rebase it please?
Comment 6 Owen Leonard 2013-05-10 12:45:46 UTC Comment hidden (obsolete)
Comment 7 Owen Leonard 2013-05-23 19:54:08 UTC Comment hidden (obsolete)
Comment 8 Galen Charlton 2013-05-24 16:31:24 UTC Comment hidden (obsolete)
Comment 9 Jonathan Druart 2013-05-27 07:43:43 UTC
QA comment:
The 3 links do the same job as before, no regression found.
Marked as Passed QA.
Comment 10 Jonathan Druart 2013-05-27 07:43:56 UTC
Created attachment 18408 [details] [review]
Bug 9424: Move JavaScript out of header include

This patch removes JavaScript "onlick" attributes from header.inc and
moves the functionality to staff-global.js. This is in keeping with the
idea of progressive enhancement.

To test, be sure to clear your browser cache after applying the patch.

- Test the help link.
- Test the logout link with the intranetbookbag preference on and off.
- Open a patron's account and click "search to hold." Log out, and log
  in again. Koha should not remember the patron you chose before
  logging out (as seen from a search results page).

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 11 Galen Charlton 2013-05-28 14:47:07 UTC
Pushed to master.  Thanks, Owen!