Bug 9438 - Biblio notes displayed when ordering
Summary: Biblio notes displayed when ordering
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.12
Hardware: All All
: P5 - low minor (vote)
Assignee: Adrien SAURAT
QA Contact: Paul Poulain
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 11:13 UTC by Adrien SAURAT
Modified: 2014-05-26 21:04 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch (1.27 KB, patch)
2013-01-21 11:16 UTC, Adrien SAURAT
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9438: biblio notes displayed when adding order (1.64 KB, patch)
2013-02-05 16:59 UTC, Owen Leonard
Details | Diff | Splinter Review
Follow-up Bug 9438 - Biblio notes displayed when ordering (2.29 KB, patch)
2013-02-05 19:47 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
[SIGNED-OFF] Follow-up Bug 9438 - Biblio notes displayed when ordering (2.34 KB, patch)
2013-02-08 17:56 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Follow-up Bug 9438 - Biblio notes displayed when ordering (2.33 KB, patch)
2013-02-08 17:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 9438: biblio notes displayed when adding order (1.66 KB, patch)
2013-03-21 08:58 UTC, Paul Poulain
Details | Diff | Splinter Review
[PASSED QA] Follow-up Bug 9438 - Biblio notes displayed when ordering (2.40 KB, patch)
2013-03-21 08:58 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien SAURAT 2013-01-21 11:13:06 UTC
[MT10894]
Two libraries warned us about this error: on the "neworderempty" page (New order in a basket), the Notes box is filled with the content of the "notes" field (from biblio).
This box should in fact be empty, used for notes about the order.

TEST PLAN
1/ Find a biblio with a note (for example 300$a in UNIMARC, don't know for USMARC?), or add a note to a biblio.

2/ In a basket, create a new order, the "Notes" textarea contains the note from the biblio.
Comment 1 Adrien SAURAT 2013-01-21 11:16:46 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2013-01-21 15:33:32 UTC
Adrien, it has always (or for a very long time) been like this. I am not a fan, but I think we maybe need to ask if people find it useful or have to keep it as an option.
Comment 3 Adrien SAURAT 2013-01-21 16:00:29 UTC
I'm not a librarian and I really don't know how it should be =)
Two librairies working with us saw this and considered this behaviour as a bug, that's all I know!
This can wait until we have other opinions on the matter, of course.
Comment 4 Katrin Fischer 2013-01-21 16:05:45 UTC
I am not sure myself - maybe we should have a field for footnotes in the bibliographic area? So no information would be lost, but we would still free up the note in the acquisition area of the form for information about the order itself.
Comment 5 mathieu saby 2013-01-22 09:18:52 UTC
Hello Karin
Adrien made the patch for us.
In the records provided par Electre (main record provider for french libraries), we have some notes in 300 UNIMARC fields (like 500 MARC21 field). For example "Contains bibliography", or "Proceedings of the 20th meeting..."
It is clearly a note describing the document, and not an "acquisition note".
But maybe some libraries/bookseller use 300 field for storing informations about the acquisition. I can ask the lists if you want.

Regards,
M. Saby
Rennes 2 University
Comment 6 Katrin Fischer 2013-01-22 09:44:14 UTC
Hi Mathieu,

I agree with you :) I am only worried because the confusing behaviour has been there for a long while. So maybe libraries do like the information to show up at least somewhere. So I think if we could just get some people to give an opinion here that would be a good thing. :)
Comment 7 mathieu saby 2013-01-28 11:18:54 UTC
Galen Charlton and Zeno Tajoli agreed with the patch.
So, Katrin, if it works, you can sign it off ;-)

M. Saby
Comment 8 Katrin Fischer 2013-01-28 11:23:37 UTC
Hi Mathieu - I saw the mails on the mailing list, thank you for asking.
I will try to sign off, but maybe better if I do QA on it instead? :)
Comment 9 mathieu saby 2013-01-28 11:31:52 UTC
Ok, I will sign it off this afternoon, so you will be able to QA if you want.
M. Saby
Comment 10 Bernardo Gonzalez Kriegel 2013-01-28 12:21:22 UTC
This patch will never show order notes.
I think that the change needs to be in
acqui/neworderempty.pl.

Something like
392:    notes => $data->{'notes'} unless ( $ordernumber eq '' ),
Comment 11 Owen Leonard 2013-02-05 16:59:17 UTC Comment hidden (obsolete)
Comment 12 Bernardo Gonzalez Kriegel 2013-02-05 18:24:56 UTC
Perhaps I'm wrong, but I found the following behavior:

1) Follow test plan after patch applied
2) In a new basket the Notes field in Accounting Details is empty 
(was the place filled with 300a/500a), patch is working!
3) Add a note and save 
4) When viewing the basket, press Modify order... and the Notes is empty!!
(the data is saved, in doubt do "select notes from aqorders")

That was the meaning of my previous comment.
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/neworderempty.tt
is used to add AND modify a order in a basket. If you remove [% notes %] from
it then will never see your Accounting Details Notes again.

I got the expected behavior using:
in .../neworderempty.tt
[% IF ( notes ) %][% notes %][% END %]

and in .../neworderempty.pl
$template->param ( notes => $data->{'notes'} ) unless ( $ordernumber eq '' );


Regards
Comment 13 Katrin Fischer 2013-02-05 18:35:28 UTC
Hi Bernardo, I think your test sounds logical - I woudl like to see this resolved. Adrien - could you take a look please?
Comment 14 Bernardo Gonzalez Kriegel 2013-02-05 19:47:56 UTC Comment hidden (obsolete)
Comment 15 Kyle M Hall 2013-02-08 17:56:27 UTC Comment hidden (obsolete)
Comment 16 Kyle M Hall 2013-02-08 17:57:05 UTC Comment hidden (obsolete)
Comment 17 Paul Poulain 2013-03-21 08:56:23 UTC
QA comment:
 * passes koha-qa.pl
 * small patch, does the job

nothing to add, pass QA
Comment 18 Paul Poulain 2013-03-21 08:58:43 UTC
Created attachment 16576 [details] [review]
[PASSED QA] Bug 9438: biblio notes displayed when adding order

The biblio notes should not appear in the "Notes" textarea
of the "New order" page, in Acquisitions.

TEST PLAN
1) Find a biblio with a note (for example 300$a in UNIMARC, 500$a
in USMARC), or add a note to a biblio.

2) In a basket, create a new order for that title. Before the patch,
the "Notes" textarea contains the note from the biblio. After the patch
the textarea is empty.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 19 Paul Poulain 2013-03-21 08:58:49 UTC
Created attachment 16577 [details] [review]
[PASSED QA] Follow-up Bug 9438 - Biblio notes displayed when ordering

This patch re-enables displying Notes when select
Modify order from basket view.

To Test:
1) After applying first patch, Notes are empty when select Modify order
2) Apply patch
3) Now Notes are visible again, unless the order is new.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Paul Poulain <paul.poulain@biblibre.com>
Comment 20 Jared Camins-Esakov 2013-03-21 13:42:28 UTC
This patch has been pushed to master.