Bug 9684 - Z39.50 Card View broken in CCSR
Summary: Z39.50 Card View broken in CCSR
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low major (vote)
Target Milestone: ---
Assignee: Colin Campbell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 14:32 UTC by Nicole C. Engard
Modified: 2014-05-26 21:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.43 KB, patch)
2013-04-26 16:17 UTC, Colin Campbell
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9684 : Correct path to compact.xsl (1.64 KB, patch)
2013-04-26 21:06 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[PASSED QA] Bug 9684 : Correct path to compact.xsl (1.97 KB, patch)
2013-04-27 10:30 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-02-21 14:32:16 UTC
When in the Z search results if you click 'Card' you get the following error:


Software error:

Could not create file parser context for file "/home/nengard/kohaclone/koha-tmpl/intranet-tmpl/ccsr/en/xslt/compact.xsl": No such file or directory at /home/nengard/kohaclone/catalogue/showmarc.pl line 62.

For help, please send mail to the webmaster (webmaster@debian), giving this error message and the time and date of the error. 


This is in 3.10 and master.
Comment 1 Colin Campbell 2013-04-26 15:45:05 UTC
catalogue/showmarc.pl constructs the path to compact.xsl incorrectly 
( it blends staff and opac bizarrely)

Have a fix - waiting on site who reported this to confirm it works for them
Comment 2 Colin Campbell 2013-04-26 16:17:58 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2013-04-26 18:57:18 UTC
Unable to reproduce on master or 3.10.x. If this is still a valid bug, please provide a test plan.
Comment 4 Nicole C. Engard 2013-04-26 21:02:08 UTC
Kyle, 

It is still a bug but only if you're using the CCSR theme:

Test plan:

* Set sys pref to use CCSR
* Do a Z39.50 Search
* Click 'card' on one of the results
* confirm that there is no error.
Comment 5 Nicole C. Engard 2013-04-26 21:06:19 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2013-04-27 10:30:07 UTC
Created attachment 17746 [details] [review]
[PASSED QA] Bug 9684 : Correct path to compact.xsl

When try to display card view of retrieved record
error occurred as compact.xsl could not be found
script was constructing path as though it was opac

Also added fallback to en version if no xsl file
found under current lang as done in opac-showmarc.pl

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Test plan:

* Set sys pref to use CCSR
* Do a Z39.50 Search
* Click 'card' on one of the results
* confirm that there is no error.

All test pass

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
I am astonished that opacthemes affects Z39.50 search in
staff so this might be fixing a bigger problem.

Checked that clicking on Card works for both themes now
correctly after I confirmed the bug.
Also all views in OPAC were checked for both themes.

All tests and QA script pass.
Comment 7 Jared Camins-Esakov 2013-04-27 11:16:38 UTC
This patch has been pushed to master and 3.12.x.
Comment 8 Chris Cormack 2013-04-27 22:00:30 UTC
Pushed to 3.10.x will be in 3.10.6