Bug 9864 - systematic searching error : can't call method "raw"
Summary: systematic searching error : can't call method "raw"
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 10:05 UTC by Koha Team University Lyon 3
Modified: 2019-06-27 09:24 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Koha Team University Lyon 3 2013-03-20 10:05:02 UTC
Launching a Search, whether on opac or intranet and whatever index is used get the following error :
"Can't call method "raw" on an undefined value at /home/kohabac/src/C4/Search.pm line 496"
Comment 1 Magnus Enger 2013-03-20 10:49:55 UTC
What kind of installation? Which MARC dialect? 

If it is a Debian-package-installation with UNIMARC, this could be a duplicate of Bug 9256. 

I had the same error on a dev-install with NORMARC, which was fixed by running the upgrade steps and reindexing.
Comment 2 Koha Team University Lyon 3 2013-03-20 11:07:36 UTC
It 's a dev install UNIMARC made by git on debian squeeze.
Comment 3 Magnus Enger 2013-03-20 13:12:53 UTC
Did you upgrade* and reindex? 

perl Makefile.PL --prev-install-log /path/to/koha-install-log
make
make test
sudo make upgrade
Comment 4 Magnus Enger 2013-04-03 19:35:07 UTC
Is this still a problem, Koha Team Lyon 3?
Comment 5 Koha Team University Lyon 3 2013-04-08 09:36:41 UTC
Hello
Sorry for my silence, I was away from Koha all these days. I will have a look at it as soon as possible.
Comment 6 Guillaume Hatt 2013-05-24 09:49:10 UTC
Hello,
I have the same problem after an "apt-get install koha-common" on Debian Squeeze, using 3.12 version packages :
Can't call method "raw" on an undefined value at /usr/share/koha/lib/C4/Search.pm line 490."
My installation is french UNIMARC, and I did a full reindexation.

Thanks.
G. Hatt
Comment 7 Koha Team University Lyon 3 2013-05-24 13:42:41 UTC
I made the update (it's already some weeks ago) as you suggested in comment 3
perl Makefile.PL --prev-install-log /home/[USER]/koha-dev/misc/koha-install-log

but seems there's a problem with dev install update :
What happens is that files present in our /home/[USER]/koha-dev/etc/zebradb repertory are saved and postfixed with current version number (something like retrieval-info-auth-grs1.xml_3.08.88 ) but new retrieval and mar files are not copied from /home/[USER]/src/etc/zebradb in it. Moreover, record.abs and koha-conf.xml aren't updated.

So I made the minimum necessary modifications by hands (only for unimarc flavour et grs1 indexation) :
first I deleted all saved files then
copied the 2 unimarc retrieval files (unimarc-retrieval-info-auth-grs1.xml and unimarc-retrieval-info-bib-grs1.xml) from /home/[USER]/src/etc/zebradb in /home/[USER]/koha-dev/zebradb
copied unimarc.mar file in /home/[USER]/koha-dev/zebradb/etc
replaced 'marc usmarc.mar' line by 'marc unimarc.mar' in record.abs 
replaced all occurrences of syntax="usmarc" by syntax="unimarc" in koha-conf.xml
reindexed and it's ok 

Olivier Crouzet
Comment 8 mathieu saby 2013-05-24 17:26:26 UTC
I never notice this problem, that's strange.
Mathieu
Comment 9 Petter Goksøyr Åsen 2013-10-08 12:01:08 UTC
Im trying to set up a dev instance of Koha following instructions here:
http://wiki.koha-community.org/wiki/Install_and_Setup_Koha_to_use_Git_on_a_Development_Server

I completed all the steps and now I'm stuck with this same error when trying to do a search.

I'll try to start over again on another machine..
Comment 10 Petter Goksøyr Åsen 2013-10-09 08:19:46 UTC
Update: problem dissapears when I installed using the squeeze-dev package instead of squeeze-main
Comment 11 Colin Campbell 2014-07-15 11:42:17 UTC
If you're getting the problem it might be interesting to see what the values of term and occ are when its generated. The Search.pm code seems to assume everything will work ok which is not a good assumption to make
Comment 12 Koha Team University Lyon 3 2014-12-04 15:21:13 UTC
This problem seems to be resolved in koha 3.18.0