Bug 9867 - Make XSLT view the default for Norwegian installations
Summary: Make XSLT view the default for Norwegian installations
Status: RESOLVED DUPLICATE of bug 10134
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Magnus Enger
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 10:21 UTC by Magnus Enger
Modified: 2013-04-27 09:22 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9867 - Make XSLT view the default for Norwegian installations (2.23 KB, patch)
2013-04-16 10:55 UTC, Magnus Enger
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2013-03-20 10:21:46 UTC
I'd like to make XSLT the default view for Norwegian installations, by adding the necessary settings to installer/data/mysql/nb-NO/1-Obligatorisk/system_preferences.sql.
Comment 1 Magnus Enger 2013-04-16 10:55:05 UTC
Created attachment 17488 [details] [review]
Bug 9867 - Make XSLT view the default for Norwegian installations

XSLT is the only view that is maintained for NORMARC, so it makes
sense for all new, Norwegian installations to use XSLT.

To test:
- Run through the Web-insatller in Norwegian, making sure that the
  (mandatory) choice "Standard systempreferanser (system_preferences)"
  is selected.
- When the Web-installer is done, check that all 4 XSLT preferences
  (OPACXSLTDetailsDisplay, OPACXSLTResultsDisplay, XSLTDetailsDisplay,
  XSLTResultsDisplay) are set to "default".
Comment 2 Magnus Enger 2013-04-26 14:30:48 UTC
Since the non-XSLT NORMARC views are not really maintained, I'd say it's a bug having them as the default view.
Comment 3 Magnus Enger 2013-04-27 09:22:25 UTC
Bug 10134 will do the same thing as this patch for *all* new installs, so I'm marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 10134 ***