Bug 9878 - Flag display is inconsistent between circulation.pl and memberentry.pl
Summary: Flag display is inconsistent between circulation.pl and memberentry.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
: 9501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-20 19:22 UTC by Jared Camins-Esakov
Modified: 2015-12-03 22:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 9878: Add consistentcy on restriction messages (1.90 KB, patch)
2015-04-09 14:25 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED OFF] Bug 9878: Add consistentcy on restriction messages (1.97 KB, patch)
2015-04-16 02:01 UTC, Nick Clemens
Details | Diff | Splinter Review
[PASSED QA] Bug 9878: Add consistentcy on restriction messages (2.03 KB, patch)
2015-04-17 05:55 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2013-03-20 19:22:31 UTC
Whereas circulation.pl has strings like "Restricted: patron's account is restricted" after the patron's name, memberentry.pl says only "Patron is restricted" before the name. I prefer the formatting on circulation.pl, but exactly how it is formatted is less important than that it be consistent.
Comment 1 Owen Leonard 2014-07-18 18:57:43 UTC
*** Bug 9501 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Druart 2015-04-09 14:25:52 UTC Comment hidden (obsolete)
Comment 3 Nick Clemens 2015-04-16 02:01:44 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2015-04-17 05:55:56 UTC
Created attachment 37993 [details] [review]
[PASSED QA] Bug 9878: Add consistentcy on restriction messages

Between both pages circ/circulation.pl and members/moremember.pl, the
restriction messages should be the same.

Test plan:
1/ Add a non-unlimited restrictions to a patron
2/ Go on both pages and confirm the restriction message is the same.

Signed-off-by: Nick Clemens <nick@quecheelibrary.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Tomás Cohen Arazi 2015-04-27 16:40:22 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 6 Chris Cormack 2015-05-17 03:55:34 UTC
Pushed to 3.18.x will be in 3.18.7