Bug 9926 - Missing perl modules in Koha
Summary: Missing perl modules in Koha
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Mason James
QA Contact: Jonathan Druart
URL:
Keywords:
Depends on:
Blocks: 9172
  Show dependency treegraph
 
Reported: 2013-03-26 05:50 UTC by Mason James
Modified: 2014-05-26 21:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9926 - Missing perl modules in Koha (790 bytes, patch)
2013-03-26 06:49 UTC, Mason James
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9926 - Missing perl modules in Koha (1.02 KB, patch)
2013-03-26 10:55 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 9926 - Missing perl modules in Koha (1.29 KB, patch)
2013-03-26 23:24 UTC, Mason James
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9926 - Missing perl modules in Koha (1.34 KB, patch)
2013-03-27 00:17 UTC, Bernardo Gonzalez Kriegel
Details | Diff | Splinter Review
Bug 9926 - Missing perl modules in Koha (1.39 KB, patch)
2013-03-28 15:55 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mason James 2013-03-26 05:50:13 UTC
File::Slurp is required in files tiny_mce_gzip.pl,benchmark_webservices.pl,koha-svc.pl
Comment 1 Mason James 2013-03-26 06:49:12 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2013-03-26 10:30:05 UTC
This patch lacks a commit message and a test plan.
Comment 3 Bernardo Gonzalez Kriegel 2013-03-26 10:55:32 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2013-03-26 12:41:26 UTC
(In reply to comment #3)
> 2) after applying patch, now it list File::Slurp as requirement.

My objection is to the lack of a description of the problem caused by the missing dependency and a way to test that the problem has gone away. Testing that the requirement shows up is only part of the process IMO.
Comment 5 Mason James 2013-03-26 23:24:21 UTC Comment hidden (obsolete)
Comment 6 Bernardo Gonzalez Kriegel 2013-03-27 00:17:37 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2013-03-28 15:54:59 UTC
QA comment:
File::Slurp is required.
I didn't test with a previous version.
Marked as Passed QA.
Comment 8 Jonathan Druart 2013-03-28 15:55:16 UTC
Created attachment 16983 [details] [review]
Bug 9926 - Missing perl modules in Koha

to test…

1) check perl syntax on file
     $ perl -cw ./misc/migration_tools/koha-svc.pl

     you should *not* get 'syntax OK' returned from command

2) apply patch, and install File::Slurp module
      $ sudo cpanm File::Slurp

3) check perl syntax on file
      $ perl -cw ./misc/migration_tools/koha-svc.pl

      you should now get 'syntax OK' returned from command

Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com>

Comment: Without File:Slurp 1) complains of missing module,
with module then sintax Ok.
No errors.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 9 Jared Camins-Esakov 2013-03-30 01:39:38 UTC
This patch has been pushed to master.