Bug 9935 - Social icons missing in CSSR theme
Summary: Social icons missing in CSSR theme
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor (vote)
Assignee: Fridolin SOMERS
QA Contact: Jonathan Druart
URL:
Keywords:
: 9193 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-27 10:04 UTC by Fridolin SOMERS
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (5.22 KB, patch)
2013-03-27 11:59 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 9935 - Social icons missing in CSSR theme (5.29 KB, patch)
2013-03-27 23:01 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 9935 - Social icons missing in CSSR theme (5.36 KB, patch)
2013-03-28 14:43 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2013-03-27 10:04:42 UTC
When using CSSR theme, opac.css is missing css rules for social networks Facebook, LinkedIn ...
Comment 1 Fridolin SOMERS 2013-03-27 11:59:57 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2013-03-27 23:01:28 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2013-03-28 14:43:21 UTC
QA comment:
Add missing icons for the social networks feature using CSSR theme.
Marked as Passed QA.
Comment 4 Jonathan Druart 2013-03-28 14:43:32 UTC
Created attachment 16973 [details] [review]
Bug 9935 - Social icons missing in CSSR theme

When using CSSR theme, opac.css is missing css rules for social networks Facebook, LinkedIn ...

This patch copies css rules related to social netxork from prog theme to cssr theme.
Also copies social-sprite.png image.

Test plan :
- Set CSSR theme : syspref opacthemes=ccsr and opaccolorstylesheet=colors.css
- Set syspref SocialNetworks=Enable
- Go to a detail page at OPAC
=> check that social links are icons : Facebook, LinkedIn, Delicious, Send by email, Google Plus and Tweeter

Signed-off-by: Liz Rea <liz@catalyst.net.nz>
Social icons now showing, thanks!

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 5 Jared Camins-Esakov 2013-03-30 01:59:12 UTC
This patch has been pushed to master.
Comment 6 Chris Cormack 2013-03-30 07:25:34 UTC
Pushed to 3.10.x will be in 3.10.5
Comment 7 Nicole C. Engard 2013-04-25 23:54:57 UTC
*** Bug 9193 has been marked as a duplicate of this bug. ***