Bug 9959 - Filters for 'Most popular' page in OPAC show wrong behaviour
Summary: Filters for 'Most popular' page in OPAC show wrong behaviour
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-31 12:17 UTC by Katrin Fischer
Modified: 2020-01-06 20:14 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-03-31 12:17:08 UTC
Testing the patch for bug 9946 I notes some strange things about the filters on the 'Most popular' (system preference OpacTopissue) page in the OPAC.

1) Why do I have to double submit my search sometimes? 
   - go to top issues from opac start page
   - change filter from last 3 months to no limit
   - submit
   - another form is shown and you have to submit again
2) Why are the search options of this second form different to the first form?
   - library changes from Union to Demo for me
3) Why does hitting the submit button on the filter left sometimes change the
   filters too?
   - library changes from all libraries to Union (last in list)
Comment 1 Owen Leonard 2013-08-13 19:23:06 UTC
I can't reproduce 1). 2) and 3) I think should be fixed by Bug 10588.
Comment 2 Nicole C. Engard 2014-05-17 18:14:30 UTC
I too am having issues with this on 3.14:

I start here: http://catalogue.buttepubliclibrary.info/cgi-bin/koha/opac-topissues.pl and then I click to change branch and submit and then it redirects me to: http://catalogue.buttepubliclibrary.info/cgi-bin/koha/opac-topissues.pl?limit=10&branch=SOUTH&timeLimit=3&do_it=1 which has no results, but does have a second search form on it.
Comment 3 Marc Véron 2014-05-18 08:42:48 UTC
.../cgi-bin/koha/admin/preferences.pl?tab=opac says: 
"OpacTopissue (...)  Note that this is somewhat experimental (...)"

In Bug 12136, Owen Leonard pointed out some more strange behaviours of OpacTopIssues.
Comment 4 Katrin Fischer 2019-04-28 10:15:15 UTC
I can't reproduce the problems I reported in 2013. Marking WORKSFORME.