Bug 9969 - Sorting budget by labels rather than by codes
Summary: Sorting budget by labels rather than by codes
Status: RESOLVED DUPLICATE of bug 13944
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Fridolin Somers
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 11:46 UTC by Sophie MEYNIEUX
Modified: 2019-04-28 10:12 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie MEYNIEUX 2013-04-02 11:46:39 UTC
When modifying a command line, budgets are proposed in a dropdown list, sorted by budget code. It would be better to have them sorted by name.
Comment 1 Owen Leonard 2018-09-12 17:03:09 UTC
Is this bug still valid? I don't understand where to find the buggy behavior.
Comment 2 Fridolin Somers 2018-09-16 22:40:29 UTC
It is still valid for me when editing an existing order :
/cgi-bin/koha/acqui/neworderempty.pl?ordernumber=1&booksellerid=3

Funds are sorted by code but name is displayed.

May be fixed like in Bug 10875 :
In acqui/addorderiso2709.pl L427 :
@{$budget_loop} =
  sort { uc( $a->{b_txt}) cmp uc( $b->{b_txt}) } @{$budget_loop};
Comment 3 Katrin Fischer 2019-04-28 10:12:50 UTC
I think budgets is funds here (we switched descriptions at one point) which makes this a duplicate of bug 13944.

*** This bug has been marked as a duplicate of bug 13944 ***