Bug 9976 - QueryAutoTruncate can break search when ICU is activated
Summary: QueryAutoTruncate can break search when ICU is activated
Status: RESOLVED DUPLICATE of bug 9715
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 19:29 UTC by Katrin Fischer
Modified: 2013-04-07 07:41 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
screenshot of configuration settings (106.15 KB, image/png)
2013-04-02 19:29 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-04-02 19:29:06 UTC
Created attachment 17149 [details]
screenshot of configuration settings

To reproduce:

Make sure Koha is installed to use ICU indexing.

Configuration settings:
IncludeSeeFromInSearches = Don't include
QueryAutoTruncate = automatically
QueryFuzzy = Try
QueryStemming = Try
QueryWeightFields = Enable
UseIcu = Using
UseQueryParser = Do not try

With this settings, search will work.

Now switch QueryAutoTruncate = only when * is added

Search won't work at all now.
Comment 1 Martin Renvoize 2013-04-03 13:22:02 UTC
Hi Katrin, 

I have a feeling that this is related to bug 9715 too.. the testing I had completed in there also had ICU indexing enabled. I haven't yet had a chance to follow up my investigations into what preference combinations work and don't work overall.  Maybe you could help on that front too?

Martin
Comment 2 Katrin Fischer 2013-04-07 07:39:21 UTC
Hi Martin, 
I have no time to test out all the various possible combinations, maybe it's a start to investigate the now known bad combinations?
Comment 3 Katrin Fischer 2013-04-07 07:41:27 UTC

*** This bug has been marked as a duplicate of bug 9715 ***