Bug 10027 - Fine details not showing when printing a fine
Summary: Fine details not showing when printing a fine
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal with 10 votes (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 17:45 UTC by Kyle M Hall
Modified: 2015-06-04 23:23 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10027 - Fine details not showing when printing a fine (1.33 KB, patch)
2013-04-10 17:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10027 - Fine details not showing when printing a fine - Tidy members/printinvoice.pl (8.25 KB, patch)
2013-04-10 17:49 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10027 - Fine details not showing when printing a fine (1.38 KB, patch)
2013-04-10 23:44 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 10027 - Fine details not showing when printing a fine - Tidy members/printinvoice.pl (8.30 KB, patch)
2013-04-10 23:46 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 10027 - Fine details not showing when printing a fine - QA Followup (2.19 KB, patch)
2013-09-05 19:28 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine (1.47 KB, patch)
2013-09-07 18:09 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine - Tidy members/printinvoice.pl (8.37 KB, patch)
2013-09-07 18:09 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine - QA Followup (2.37 KB, patch)
2013-09-07 18:09 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-04-10 17:45:01 UTC
Previously printing a fine invoice would result in a page with both the single item charge and the total outstanding dues. Right now only the total outstanding is printed.
Comment 1 Kyle M Hall 2013-04-10 17:46:23 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2013-04-10 17:49:48 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2013-04-10 23:44:59 UTC Comment hidden (obsolete)
Comment 4 Chris Cormack 2013-04-10 23:46:08 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2013-04-22 06:27:13 UTC
This is better, but not quite there yet. I have checked the print for a partially paid fine and it still shows the full amount instead of the amount left to pay.

Upping bug severity a bit.
Comment 6 Kyle M Hall 2013-09-05 19:28:56 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-09-07 18:05:51 UTC
I think this works as intended now, but it would be good if all fine lines showed not just the one you clicked - that would make more sense of the total given.
Comment 8 Katrin Fischer 2013-09-07 18:09:04 UTC
Created attachment 20851 [details] [review]
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine

Previously printing a fine invoice would result in a page with both the
single item charge and the total outstanding dues. Right now only the
total outstanding is printed.

Test Plan:
1) Print a fine, note the fine doesn't show, only the total
2) Apply patch
3) Print a fine, not the fine does show

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comments on third patch.
Comment 9 Katrin Fischer 2013-09-07 18:09:20 UTC
Created attachment 20852 [details] [review]
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine - Tidy members/printinvoice.pl

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 10 Katrin Fischer 2013-09-07 18:09:28 UTC
Created attachment 20853 [details] [review]
[PASSED QA] Bug 10027 - Fine details not showing when printing a fine - QA Followup

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.

Checked invoice is correctly printed for
- partially paid fines
- paid fines
- unpaid fines
Comment 11 Galen Charlton 2013-09-08 06:29:12 UTC
Pushed to master.  Thanks, Kyle!
Comment 12 Tomás Cohen Arazi 2013-11-01 17:47:51 UTC
This patch has been pushed to 3.12.x, will be in 3.12.7.

Thanks Kyle!