Bug 10047 - Cataloguing search maybe useless?
Summary: Cataloguing search maybe useless?
Status: RESOLVED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
: 2136 (view as bug list)
Depends on:
Blocks: 20396
  Show dependency treegraph
 
Reported: 2013-04-14 13:49 UTC by mathieu saby
Modified: 2023-01-25 22:15 UTC (History)
14 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mathieu saby 2013-04-14 13:49:53 UTC
I dont see the goal of cataloguing search (/cataloguing/addbooks.pl), except it searches also in the reservoir.

When I search a record, I use ordinary catalog search, and I click on "Edit" button. And most of our librarians are doing so.
Moreover, the new "Cancel" button on /cataloguing/addbiblio.pl page send you back to "Detail" page, even if you have come to addbiblio.pl from addbooks page.

So maybe we could get rid of cataloguing search, and add an option to see records of the reservoir in normal search ?

Mathieu Saby
Comment 1 Katrin Fischer 2013-04-14 13:58:17 UTC
Hm, maybe when nothing is found in search, we could forward to the cataloguing search for a search in the reservoir. So if you don't find what you are looking for, expand search into the cataloguing search to check the reservoir, then repeat that search with z39.50.

Right now I don't see how we could integrate the reservoir search into the normal search well. Having a tool more dedicated to cataloguers makes sense to me, but maybe the page and the functionality needs some thought.
Comment 2 mathieu saby 2013-04-14 14:03:30 UTC
It was just an idea...
Having 2 places in Koha for searching records seems strange when you have used other ILS.

Moreover, is not it a potential source of bugs to maintain 2 files for the same purpose (searching records)?

M. Saby
Comment 3 Katrin Fischer 2013-04-14 14:40:15 UTC
I think the reservoir is not Zebra, but only MySQL search. So it would probably not be so easy to merge those 2. Maybe it should just be a reservoir search?
Comment 4 Liz Rea 2013-04-15 04:48:58 UTC
I have always found this extremely odd as well - I would like to hear librarians tell us what they like about the cataloguing search (in addition to the reservoir) so that we can integrate that into the main search and eliminate the cataloguing search.

It's confusing and needs to go away.
Comment 5 Nicole C. Engard 2013-04-26 00:35:03 UTC
The history of this is that the cataloging search used to be the only place with the edit items and edit record links ... but now that's on the regular search as well so I agree it's still to have two searches.  I think the cataloging search should only search the reservoir and be renamed such.
Comment 6 mathieu saby 2013-04-26 07:11:26 UTC
Maybe we could suppress cataloguing search, and add a button in normal search to enlarge the scope of the search to include the reservoir if the librarian wants to do so and have permissions?

M. Saby
Comment 7 Chris Cormack 2013-08-19 19:30:41 UTC
(In reply to Nicole C. Engard from comment #5)
> The history of this is that the cataloging search used to be the only place
> with the edit items and edit record links ... but now that's on the regular
> search as well so I agree it's still to have two searches.  I think the
> cataloging search should only search the reservoir and be renamed such.

Not entirely true, you could always edit biblios and items from the staff Catalogue, even as far back as 1.0. Back then there was also the catalogue maintenance module where you could undelete biblio and items, and move items to different biblioitems (groups).

Cataloguing search has also always been there, because yes it searches not only what is in the catalogue but what has been staged also. In one search. 

I'd like to be sure people aren't using it before we attempt yet another refactoring exercise and cause regressions.
Comment 8 Galen Charlton 2013-08-19 19:37:31 UTC
An additional point -- there are targets where it can cost money to perform Z39.50 searches ... per search!  I believe that this was the case with OCLC at one point, and there may be other cases.  The reservoir offers a way of reducing cataloging costs by checking it first before resorting to a Z39.50 search.

How well this works in practice, I don't know, but I would be curious to hear from catalogers who use Koha on a daily basis.
Comment 9 Nicole C. Engard 2013-09-03 11:53:19 UTC
*** Bug 2136 has been marked as a duplicate of this bug. ***
Comment 10 Nick Clemens 2014-04-23 02:16:22 UTC
As a regular cataloger I have always avoided cataloging search since, in the versions we have used, ISBNs did not normalize and I couldn't use the search commands (ti:, au: etc)  I have also encountered sorting issues like finding exact title matches far down or on later pages.

I think most catalogers in our consortia do use the 'cataloging' search, but I suspect that is mostly because of the name and that is how they were trained. 

I would be very happy to see reservoir search as a tab option in the header with focus on the 'search the catalog tab'

Just my two cents
Comment 11 Agnes Rivers-Moore 2018-03-06 22:43:20 UTC
Just in case anyone ever revisits this one...
As a librarian, having the reservoir separate is a benefit to non-cataloguing staff. When cataloguers search they expect to find records that are not in library stock. For other staff it is confusing to read through multiple variations of a title, looking for the one that has a live item. For that reason reservoir records need to be filtered out from staff searches somehow.
From the technical standpoint, there may be advantages in not loading lots of records to Zebra/Elasticsearch and having system resources spent on fully indexing them, when they may never be added as stock. Z39.50 loads MARC records for all search hits to reservoir. Cataloguers pick one variant, but the rest live on in reservoir until cleaned out. From experience, the reservoir can become larger than the library stock database in as little as a year or so, depending on cataloguing practice.
Comment 12 Gaetan Boisson 2018-03-16 08:50:55 UTC
I fully agree with Nick here.

The way i see it we should remove this odd search, have the normal catalog search as default in the cataloging module, and an extra tab to search just the reservoir.

Giving trainings to librarians on a very regular basis, this has been confusing as hell. It's hard to explain to users that, because they are in the cataloging module, they don't get all the search features they are used to. Catalogers really miss having facets and sorts and all the nice things they have on the normal search, and because it's the default and the name is confusing ("cataloging search" instead of "search the catalog") they really have no idea why the display is so different.

Also, if what you do want to do is search the reservoir, then you need to scroll all the way down to find you results.

So yes, a dedicated reservoir search, with regular search being the default for the cataloging module, would definitely make me happy!
Comment 13 Elaine Bradtke 2018-04-23 16:42:18 UTC
Librarian here:
We don't generally use the cataloguing search.  I will use it in the test site, to check the reservoir on rare occasions. But the rest of the staff ignore that option. In the odd instances they accidently use that search they are slightly perplexed by the reservoir results. From the perspective of our library - the option of searching the reservoir is useful, but rarely used, and not by the average cataloguer, but by the person who uploads data into Koha.
Comment 14 Barbara Johnson 2018-06-13 15:38:38 UTC
Our catalogers use the cataloguing search (/cataloguing/addbooks.pl) on a daily basis.  We're able to easily find our records at the top of the list.  We don't really pay any attention to the records in the reservoir.  For me, the display at cataloguing search (/cataloguing/addbooks.pl is cleaner.  It displays less information making it easier for me to detect the records I want to work with.  Also, I do much less scrolling since I don't have to look at a longer display for each record that includes the items.  Personally, I don't want it to go away.  Maybe it could be a system preference to turn on/off. Or maybe libraries that don't want to see it could hide the buttons and links with some css/jquery.  Just my two cents.

Barbara Johnson
Comment 15 Cori Lynn Arnold 2019-11-11 13:56:34 UTC
Librarian here: 

We currently use the cataloging search because the Advanced Search doesn't support searching by control number. We would prefer that the Advanced Search supports searching the control number as well as searching in the reservoir (for control number and the currently available fields). I agree with Barbara Johnson, make the search configurable for those that are confused and want to get rid of it. Then make the configurable preference of either the Basic or Advanced editor the default.

I would ultimately prefer that a search works the same weather you are searching in the catalog, the reservoir, or Z39.50. There are a three searching interfaces in Koha in the cataloging tab and they all are drastically different and return different things. Why not have one, efficient interface that does the same thing?
Comment 16 Katrin Fischer 2019-11-11 20:03:57 UTC
(In reply to Cori Lynn Arnold from comment #15)
> Librarian here: 
> 
> We currently use the cataloging search because the Advanced Search doesn't
> support searching by control number. 

Hi Cori, 001 should be indexed as Control-number and be searchable. You could add it to advanced search pull downs using jQuery - would that help of have you already tried and found something not working?
Comment 17 Cori Lynn Arnold 2019-11-11 20:48:21 UTC
(In reply to Katrin Fischer from comment #16)

> Hi Cori, 001 should be indexed as Control-number and be searchable. You
> could add it to advanced search pull downs using jQuery - would that help of
> have you already tried and found something not working?

Katrin,

Can you elaborate on this? Point me to some documentation? Which interface?
Comment 18 Katrin Fischer 2019-11-24 14:08:42 UTC
(In reply to Cori Lynn Arnold from comment #17)
> (In reply to Katrin Fischer from comment #16)
> 
> > Hi Cori, 001 should be indexed as Control-number and be searchable. You
> > could add it to advanced search pull downs using jQuery - would that help of
> > have you already tried and found something not working?
> 
> Katrin,
> 
> Can you elaborate on this? Point me to some documentation? Which interface?

Verified on IRC that we talked about different things - Cori wants this for the Z39.50/catalog search in the advanced cataloguing editor. I was thinking regular Advanced search.
Comment 19 Yan Yu 2020-09-24 17:22:04 UTC
Cataloging search is useful. 
if you want to merge two records (like duplicated titles with different holdings), you can only do it after you do "Cataloging search", you cannot do it under "Search the Catalog", so Cataloging search is useful for catalogers. If there is another way to do title merge, please let me know.
Comment 20 Katrin Fischer 2020-09-24 18:15:55 UTC
(In reply to Yan Yu from comment #19)
> Cataloging search is useful. 
> if you want to merge two records (like duplicated titles with different
> holdings), you can only do it after you do "Cataloging search", you cannot
> do it under "Search the Catalog", so Cataloging search is useful for
> catalogers. If there is another way to do title merge, please let me know.

Hi Yan, in current versions of Koha you can merge records form the normal catalog search. You can also merge records from lists.
Comment 21 Esther Melander 2021-01-21 19:05:38 UTC
Having two separate searches is useful in a multi-branch installation with a shared catalog of bib records. In our case, we added javascript to limit the catalog search to return results for items of the current home branch. The cataloging search will search all bib records in the system including the reservoir. Our consortium would not want to lose this functionality.
Comment 22 Katrin Fischer 2023-01-25 22:15:32 UTC
I lot of people have spoken in favor of the cataloging search. Maybe we could still improve its looks or functionality, but possibly this should go on separate bugs. 

I am closing this WONTFIX. Please reopen if you disagree!