Bug 10311 - Holds queue ignores item-level holds where only one items exists
Summary: Holds queue ignores item-level holds where only one items exists
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact:
URL:
Keywords:
: 9950 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-22 13:52 UTC by Kyle M Hall
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10311 - Holds queue ignores item-level holds where only one items exists (1.33 KB, patch)
2013-05-22 13:55 UTC, Kyle M Hall
Details | Diff | Splinter Review
[Signed off] Bug 10311 - Holds queue ignores item-level holds where only one items exists (1.40 KB, patch)
2013-05-23 22:44 UTC, Melia Meggs
Details | Diff | Splinter Review
Bug 10311 - Holds queue ignores item-level holds where only one items exists (1.44 KB, patch)
2013-06-08 04:01 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-05-22 13:52:29 UTC
If a record has only one item, and that item has one item-level hold on it, that hold will not show in the holds queue.
Comment 1 Kyle M Hall 2013-05-22 13:55:04 UTC Comment hidden (obsolete)
Comment 2 Johnny Rotten 2013-05-23 20:15:45 UTC
I've tested this patch on the VALNet production server and it works as expected.

George Williams
Comment 3 Melia Meggs 2013-05-23 22:44:53 UTC Comment hidden (obsolete)
Comment 4 Melia Meggs 2013-05-23 22:45:20 UTC
I'm adding the sign off on behalf of George.
Comment 5 Chris Cormack 2013-06-08 04:01:05 UTC
Created attachment 18778 [details] [review]
Bug 10311 - Holds queue ignores item-level holds where only one items exists

If a record has only one item, and that item has one item-level hold on
it, that hold will not show in the holds queue.

Test Plan:
1) Create 1 record with 1 item at BranchA
2) Create an item-level hold for that item, for pickup at BranchA by a
   patron of BranchA
3) Run build_holds_queue.pl
4) View the holds queue for BranchA
5) Note the hold is not in there
6) Apply this patch
7) Re-run build_holds_queue.pl
8) View the holds queue again
9) Not that the hold is now there

Signed-off-by: George Williams <georgew@latahlibrary.org>
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 6 Galen Charlton 2013-06-10 16:22:42 UTC
Pushed to master.  Thanks, Kyle!
Comment 7 Tomás Cohen Arazi 2013-06-12 18:49:34 UTC
This patch has been pushed to 3.12.x, will be in 3.12.1.

Great work Kyle!
Comment 8 Bernardo Gonzalez Kriegel 2013-07-08 13:31:17 UTC
Pushed to 3.10.x, will be in 3.10.8
Comment 9 Liz Rea 2013-07-19 02:55:02 UTC
*** Bug 9950 has been marked as a duplicate of this bug. ***