Bug 10504 - C4::Acquisition::ModOrderItem is unused
Summary: C4::Acquisition::ModOrderItem is unused
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-25 07:13 UTC by Jonathan Druart
Modified: 2014-12-07 20:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.27 KB, patch)
2013-06-25 07:15 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.64 KB, patch)
2013-07-01 08:05 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.61 KB, patch)
2013-07-11 03:19 UTC, Srdjan Jankovic
Details | Diff | Splinter Review
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.65 KB, patch)
2013-07-15 12:26 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.69 KB, patch)
2013-07-15 12:34 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine (2.69 KB, patch)
2013-07-15 12:36 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2013-06-25 07:13:32 UTC

    
Comment 1 Jonathan Druart 2013-06-25 07:15:25 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-06-29 10:01:09 UTC
Comment on attachment 19220 [details] [review]
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine

Review of attachment 19220 [details] [review]:
-----------------------------------------------------------------

C4/Acquistion.pm still is exporting ModOrderItem, so we need to clean that too.
grep ModOrderItem -r *                              
C4/Acquisition.pm:        &NewOrderItem &ModOrderItem &ModItemOrder
Comment 3 Jonathan Druart 2013-07-01 08:05:04 UTC Comment hidden (obsolete)
Comment 4 Srdjan Jankovic 2013-07-11 03:19:01 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2013-07-12 14:22:47 UTC
koha-qa.pl gives this failure

 FAIL   C4/Acquisition.pm
   FAIL   pod
                *** WARNING: No items in =over  / =back list  in file C4/Acquisition.pm
*** ERROR: Spurious text after =cut  in file C4/Acquisition.pm

I don't believe this is a result of your patch though. However, looking at the diff for your patch, I see file_not_specified_in_diff, which doesn't look like something we want to have in there!
Comment 6 Jonathan Druart 2013-07-15 08:22:48 UTC
Kyle,

I cannot reproduce:

$ git reset --hard origin/master

$ git bz apply 10504
Bug 10504 - C4::Acquisition::ModOrderItem is unused

19537 - [SIGNED-OFF] Bug 10504: Remove the unused C4::Acq::ModOrderItem routine

Apply? [(y)es, (n)o, (i)nteractive] y
Applying: Bug 10504: Remove the unused C4::Acq::ModOrderItem routine

$ qa -c 1 -v 2
testing 1 commit(s) (applied to 275f405 'Bug 10514: improve visibility of Add ')

 OK	C4/Acquisition.pm
   OK	  pod
   OK	  forbidden patterns
   OK	  valid
   OK	  critic

 OK	cataloguing/moveitem.pl
   OK	  pod
   OK	  forbidden patterns
   OK	  valid
   OK	  critic
Comment 7 Kyle M Hall 2013-07-15 12:26:16 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2013-07-15 12:27:56 UTC
Confirmed, I have no idea how I got that error. However, the more important issue to me is the file_not_specified_in_diff you can see looking here: http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=19650&action=diff
Comment 9 Marcel de Rooy 2013-07-15 12:34:21 UTC Comment hidden (obsolete)
Comment 10 Marcel de Rooy 2013-07-15 12:36:16 UTC
Created attachment 19653 [details] [review]
Bug 10504: Remove the unused C4::Acq::ModOrderItem routine

This routine has been introduced by commit 2d90fb22d43db986547bbaa945873d6dd78aab71.
The only call has been removed by commit 9eba7dc594fc0d4698da5e791d5f6f8682b2712a.

So now, this routine is useless.

Signed-off-by: Srdjan <srdjan@catalyst.net.nz>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 11 Marcel de Rooy 2013-07-15 12:37:43 UTC
Kyle, I edited the lines with the commit id's in the commit message.
Now this display problem is gone.
But this seems to not to worry git itself, just bugzilla..
Comment 12 Marcel de Rooy 2013-07-15 12:38:35 UTC
Status back to Signed off ?
Comment 13 Kyle M Hall 2013-07-15 12:38:47 UTC
Excellent! Thanks!
Comment 14 Marcel de Rooy 2013-07-15 12:39:33 UTC
I have no errors while running koha-qa.
Comment 15 Galen Charlton 2013-07-15 16:07:06 UTC
Pushed to master.  Thanks, Jonathan!
Comment 16 Tomás Cohen Arazi 2013-07-25 17:16:33 UTC
This patch has been pushed to 3.12.x, will be in 3.12.3.

Thanks Jonathan!
Comment 17 Bernardo Gonzalez Kriegel 2013-08-05 00:35:36 UTC
Pushed to 3.10.x, will be in 3.10.10