Bug 10771 - three disused scripts in misc/cronjobs/stats should be removed
Summary: three disused scripts in misc/cronjobs/stats should be removed
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Galen Charlton
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks: 10426
  Show dependency treegraph
 
Reported: 2013-08-20 19:03 UTC by Galen Charlton
Modified: 2014-12-07 20:02 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10771: remove disused statistical reports cronjobs (17.26 KB, patch)
2013-08-20 19:17 UTC, Galen Charlton
Details | Diff | Splinter Review
Bug 10771: remove disused statistical reports cronjobs (17.31 KB, patch)
2013-09-06 08:52 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 10771: remove disused statistical reports cronjobs (17.38 KB, patch)
2013-09-06 17:19 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Charlton 2013-08-20 19:03:28 UTC
The following scripts in misc/cronjobs/stats/ were added in 2008:

monthly_circulation_statistics.pl
monthly_new_items_statistics.pl
monthly_new_patron_statistics.pl

The commit message indicate that they were added for the Athens County Public Library.  IRC conversation with Owen Leonard today indicates that ACPL doesn't use them at present.  The commit message also says that "they don't work 100% with stock 3.0 yet".

All three scripts make reference to a column that doesn't exist, biblioitems.ccode, and attempts to run them result in a lot of warning messages.  There's been next to no work on them over the years.

Consequently, I think that they should be removed as dead code.
Comment 1 Galen Charlton 2013-08-20 19:17:35 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-09-06 08:52:48 UTC Comment hidden (obsolete)
Comment 3 Kyle M Hall 2013-09-06 17:19:30 UTC
Created attachment 20834 [details] [review]
Bug 10771: remove disused statistical reports cronjobs

This patch removes three cronjobs that are believed to be
unused for the following reasons:

[1] The commit message that introduces them indicates that they
    were written for a particular library.  A staff member from
    that library has confirmed that they are not in use.
[2] The scripts have received essentially no patches since they
    were introduced except for being caught up in a broader
    code-improvement patch.
[3] They refer to a column that no longer exists in biblioitems.
[4] They no longer adhere to guidelines for command-line utilities,
    and there's been no sign that anybody has felt the urge to
    correct that.
[5] They are not referenced by another code or the manual, and
    the mailing list archives do not include any substantive discussion
    of their use.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Galen Charlton 2013-09-06 18:26:57 UTC
Pushed to master.