Bug 10823 - add class info to enumchron data in detail.tt, for better styling
Summary: add class info to enumchron data in detail.tt, for better styling
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Mason James
QA Contact: Testopia
URL:
Keywords:
Depends on: 10825
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 04:09 UTC by Mason James
Modified: 2014-12-07 20:07 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (1.91 KB, patch)
2013-09-05 04:25 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (1.73 KB, patch)
2014-03-31 18:21 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (1.90 KB, patch)
2014-04-14 06:01 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 10823 - Follow up to correct problem with origin patch (2.11 KB, patch)
2014-04-14 06:06 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 10823 - Follow up to correct problem with origin patch (2.22 KB, patch)
2014-04-14 06:13 UTC, Mark Tompsett
Details | Diff | Splinter Review
Bug 10823 - Follow up to add <span> to '--' (1.25 KB, patch)
2014-04-14 11:38 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - Follow up to correct problem with origin patch (2.32 KB, patch)
2014-04-14 11:41 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - Follow up to add <span> to '--' (1.25 KB, patch)
2014-04-14 11:45 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (2.38 KB, patch)
2014-04-14 12:27 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (2.47 KB, patch)
2014-04-14 12:40 UTC, Mason James
Details | Diff | Splinter Review
Bug 10823 - add class info to enumchron data in detail.tt, for better styling (3.51 KB, patch)
2014-04-14 18:42 UTC, Mark Tompsett
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10823 - add class info to enumchron data in detail.tt, for better styling (3.62 KB, patch)
2014-04-24 13:22 UTC, Owen Leonard
Details | Diff | Splinter Review
[PASSED QA] Bug 10823 - add class info to enumchron data in detail.tt, for better styling (3.74 KB, patch)
2014-04-26 12:48 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mason James 2013-09-05 04:09:07 UTC
this is a trivial patch with no functional change

this patch adds class info to the item.serialseq and item.publisheddate values, to allow better styling
Comment 1 Mason James 2013-09-05 04:25:21 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2014-03-15 10:09:43 UTC
Marking this 'Needs Signoff', as it has a patch, but we need to check if the change is still needed and we might prefer using a <span> instead of a <div> tag.
Comment 3 Mark Tompsett 2014-03-16 16:33:33 UTC
How does this related to bug 10825?
Comment 4 Nicole C. Engard 2014-03-22 02:53:35 UTC
After applying this patch all info in the enumchron column in the staff client disappeared for me ...
Comment 5 Mark Tompsett 2014-03-22 03:24:40 UTC
Comment on attachment 20790 [details] [review]
Bug 10823 - add class info to enumchron data in detail.tt, for better styling

Review of attachment 20790 [details] [review]:
-----------------------------------------------------------------

::: koha-tmpl/intranet-tmpl/prog/en/modules/catalogue/detail.tt
@@ +513,5 @@
> +                                [% END %]
> +                                [% IF ( itemloo.serialseq ) %]
> +                                    <div class="serialseq"> -- [% itemloo.serialseq %]</div>
> +                                [% END %]
> +                                [% IF ( itemloo.publisheddate ) %]

These say 'itemloo' vs. 'item' in the previous code. This is why it disappeared for Nicole.
Comment 6 Mark Tompsett 2014-03-31 18:21:47 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2014-03-31 18:56:40 UTC
Comment on attachment 26709 [details] [review]
Bug 10823 - add class info to enumchron data in detail.tt, for better styling

Hm, why a div and not a span?
Comment 8 Mark Tompsett 2014-04-14 06:01:14 UTC Comment hidden (obsolete)
Comment 9 Mark Tompsett 2014-04-14 06:06:58 UTC Comment hidden (obsolete)
Comment 10 Mark Tompsett 2014-04-14 06:13:13 UTC Comment hidden (obsolete)
Comment 11 Mason James 2014-04-14 11:38:34 UTC Comment hidden (obsolete)
Comment 12 Mason James 2014-04-14 11:41:52 UTC Comment hidden (obsolete)
Comment 13 Mason James 2014-04-14 11:45:44 UTC Comment hidden (obsolete)
Comment 14 Mason James 2014-04-14 11:47:07 UTC
bug needs sign-off on patch 1 and 3...
Comment 15 Mason James 2014-04-14 12:27:00 UTC Comment hidden (obsolete)
Comment 16 Mason James 2014-04-14 12:40:38 UTC Comment hidden (obsolete)
Comment 17 Mark Tompsett 2014-04-14 18:42:20 UTC Comment hidden (obsolete)
Comment 18 Owen Leonard 2014-04-24 13:22:50 UTC Comment hidden (obsolete)
Comment 19 Katrin Fischer 2014-04-26 12:48:09 UTC
Created attachment 27650 [details] [review]
[PASSED QA] Bug 10823 - add class info to enumchron data in detail.tt, for better styling

Bug 10825 removes a duplicate (enumchron==serialseq).
This patch was developed on top of it. It properly styles
the elements.  These include:
- items.enumchron
- the separator used
- serial.serialseq
- items.publisheddate

As per Katrin's and Owen's suggestion, <span> was used instead
of <div>. (See comment #7 and
http://irc.koha-community.org/koha/2014-04-03#i_1491135)

TEST PLAN
---------
1) Apply patch 10825
2) Find a biblio where the enumchron and serialseq are different.
   -- in MySQL:
      SELECT items.biblionumber,items.enumchron,serial.serialseq
      FROM items,serial,serialitems
      WHERE items.itemnumber=serilaitems.itemnumber
        AND serialitems.serialid=serial.serialid;
3) In the staff client, view the source for that item.
   -- It should be one class for the entire <td> cell.
4) Apply patch 10823
5) Refresh the page
6) Look at the source for that item again.
   -- It should have <span> tags around the 4 things listed
      above.
7) Run the koha qa test tools.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

NOTE: Since there was lots of squashing and rebasing, could you
      please test and sign this off as well, Mason?

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Template change only, no regression found.
Using [%- -%] could improve readability of HTML source code.
Comment 20 Galen Charlton 2014-04-27 22:03:26 UTC
Pushed to master.  Thanks, Mason!