Bug 10957 - 710$a with 710$b (subordinate unit) present shows wrong (XSLT)
Summary: 710$a with 710$b (subordinate unit) present shows wrong (XSLT)
Status: RESOLVED DUPLICATE of bug 12465
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-26 17:48 UTC by Tomás Cohen Arazi
Modified: 2014-08-11 17:48 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
sample (201.56 KB, image/png)
2013-09-26 17:48 UTC, Tomás Cohen Arazi
Details
Bug 10957: 710$a with 710$b (subordinate unit) present shows wrong (XSLT) (7.66 KB, patch)
2013-09-26 18:19 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
710$a with 710$b (subordinate unit) present shows wrong (XSLT) (7.71 KB, patch)
2013-10-10 10:33 UTC, Paola Rossi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2013-09-26 17:48:48 UTC Comment hidden (obsolete)
Comment 1 Tomás Cohen Arazi 2013-09-26 18:19:23 UTC Comment hidden (obsolete)
Comment 2 I'm just a bot 2013-09-29 06:22:40 UTC
Patch applied cleanly, go forth and signoff
Comment 3 Paola Rossi 2013-10-10 10:33:00 UTC
Created attachment 21941 [details] [review]
710$a with 710$b (subordinate unit) present shows wrong (XSLT)

I sign off the patch
Comment 4 Katrin Fischer 2013-11-20 22:50:15 UTC
Hi Tomas, 

what i did was using an authority with $a $b $b (as $b is noted as repeatable). The generated string looked like this:

Staff detail:
 a. b, -- c.

Staff result:
 a. b

I wonder about the different generation of the display in result and detail. I think that the punctuation should be cataloged with the record, so maybe -- would not be needed. But, I am not really sure how this should look like. 

Note: a separeate patch will be needed for the bootstrap OPAC.

Leaving as 'signed off', but please comment.
Comment 5 Kyle M Hall 2013-11-22 18:30:41 UTC
Question: does this need a unimarc followup, or does this bug not affect unimarc?
Comment 6 Katrin Fischer 2013-11-25 07:18:02 UTC
I think the fields and XSLT stylesheets for UNIMARC are quite different, so I think this could go with a MARC21 patch only.
Tomas, could you take a look at my comments in comment 4?
Comment 7 Tomás Cohen Arazi 2013-12-03 22:00:33 UTC
(In reply to Katrin Fischer from comment #4)
> Hi Tomas, 
> 
> what i did was using an authority with $a $b $b (as $b is noted as
> repeatable). The generated string looked like this:
> 
> Staff detail:
>  a. b, -- c.
> 
> Staff result:
>  a. b
> 
> I wonder about the different generation of the display in result and detail.
> I think that the punctuation should be cataloged with the record, so maybe
> -- would not be needed. But, I am not really sure how this should look like. 
> 
> Note: a separeate patch will be needed for the bootstrap OPAC.
> 
> Leaving as 'signed off', but please comment.

Jared told me on IRC it was customary to use -- for $c. In any case, I just left it as it was before (if i recall).
Comment 8 Tomás Cohen Arazi 2014-08-11 17:48:18 UTC

*** This bug has been marked as a duplicate of bug 12465 ***