Bug 11746 - Add edit item links to record details page
Summary: Add edit item links to record details page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 11840 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-12 12:47 UTC by Kyle M Hall
Modified: 2015-06-04 23:30 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11746 - Add edit item links to record details page (1.86 KB, patch)
2014-02-12 12:49 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11746 - Add edit item links to record details page (1.95 KB, patch)
2014-02-12 13:55 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 11746 [QA Followup] - Add edit item links to record details page (1.71 KB, patch)
2014-02-13 14:21 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11746 [QA Followup 2] - Disable sorting on Edit column (1.05 KB, patch)
2014-02-13 18:41 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11746 - Add edit item links to record details page (2.00 KB, patch)
2014-02-13 18:48 UTC, Melissa Lefebvre
Details | Diff | Splinter Review
Bug 11746 [QA Followup] - Add edit item links to record details page (1.76 KB, patch)
2014-02-13 18:49 UTC, Melissa Lefebvre
Details | Diff | Splinter Review
Bug 11746 [QA Followup 2] - Disable sorting on Edit column (1.11 KB, patch)
2014-02-13 18:49 UTC, Melissa Lefebvre
Details | Diff | Splinter Review
Bug 11746 [QA Followup 3] (1.03 KB, patch)
2014-02-24 13:07 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11746 - Add edit item links to record details page (2.02 KB, patch)
2014-02-25 09:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11746 [QA Followup] - Add edit item links to record details page (1.84 KB, patch)
2014-02-25 09:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11746 [QA Followup 2] - Disable sorting on Edit column (1.17 KB, patch)
2014-02-25 09:14 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 11746 [QA Followup 3] Fix Javascript error (1.23 KB, patch)
2014-02-25 09:14 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-02-12 12:47:33 UTC
In order to edit a specific item right now, one must select the edit pulldown, then choose edit items, the click the edit link for the particular item the librarian wishes to edit. It would be much more convenient to have an edit link for each specific item in the items table on the record details page.
Comment 1 Kyle M Hall 2014-02-12 12:49:12 UTC Comment hidden (obsolete)
Comment 2 Marcel de Rooy 2014-02-12 13:54:28 UTC
Hi Kyle
I would also like a more direct way to edit the item.
I am not sure if this new Edit column not deviates from the current design with the check buttons for delete or batch modify, and the link on barcode.
But it works..
Will leave this problem to the QAer on duty :)
Comment 3 Marcel de Rooy 2014-02-12 13:55:33 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2014-02-12 14:16:16 UTC
The edit link should not be shown to users who don't have permission to edit.
Comment 5 Kyle M Hall 2014-02-13 14:21:53 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2014-02-13 14:22:40 UTC
(In reply to Owen Leonard from comment #4)
> The edit link should not be shown to users who don't have permission to edit.

Wow, I can't believe I forgot to check permissions! Followup submitted!

Kyle
Comment 7 Havilah Lyon 2014-02-13 18:40:16 UTC
Tested it and it works as described. Great job, Kyle!
Comment 8 Kyle M Hall 2014-02-13 18:41:30 UTC Comment hidden (obsolete)
Comment 9 Melissa Lefebvre 2014-02-13 18:48:54 UTC Comment hidden (obsolete)
Comment 10 Melissa Lefebvre 2014-02-13 18:49:31 UTC Comment hidden (obsolete)
Comment 11 Melissa Lefebvre 2014-02-13 18:49:59 UTC Comment hidden (obsolete)
Comment 12 Jonathan Druart 2014-02-17 11:42:46 UTC
I got a JS error on goind on catalogue/detail.pl

DataTables warning (table id = 'DataTables_Table_0'): Requested unknown parameter '9' from the data source for row 0

If there is no course reserve, there are no 10 columns.


Marked as Failed QA.
Comment 13 Kyle M Hall 2014-02-24 13:07:35 UTC Comment hidden (obsolete)
Comment 14 Jonathan Druart 2014-02-25 09:14:26 UTC
Created attachment 25607 [details] [review]
Bug 11746 - Add edit item links to record details page

In order to edit a specific item right now, one must select the edit
pulldown, then choose edit items, the click the edit link for the
particular item the librarian wishes to edit. It would be much more
convenient to have an edit link for each specific item in the items
table on the record details page.

Test Plan:
1) Apply this patch
2) View the record details for a record with items
3) Click the edit link for a particular item
4) Note that you are taken immediately to the item editor
   for this particular item

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Havilah Lyon <havilah@aflibrary.org>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 15 Jonathan Druart 2014-02-25 09:14:31 UTC
Created attachment 25608 [details] [review]
Bug 11746 [QA Followup] - Add edit item links to record details page

Signed-off-by: Havilah Lyon <havilah@aflibrary.org>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 16 Jonathan Druart 2014-02-25 09:14:38 UTC
Created attachment 25609 [details] [review]
Bug 11746 [QA Followup 2] - Disable sorting on Edit column

Signed-off-by: Havilah Lyon <havilah@aflibrary.org>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 17 Jonathan Druart 2014-02-25 09:14:43 UTC
Created attachment 25610 [details] [review]
Bug 11746 [QA Followup 3] Fix Javascript error

DataTables warning (table id = 'DataTables_Table_0'): Requested unknown
parameter '9' from the data source for row 0

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 18 Galen Charlton 2014-02-26 16:10:21 UTC
Pushed to master.  Thanks, Kyle!

However, I am declining to push the second and third follow-ups, as they are not comprehensive enough -- if a staff user lacks permission to edit items, and spine label printing is off, and there are no analytics, the last column that would be made non-sortable would be an item information column.  Leaving the edit column sortable for now is the lesser evil.

I will open a new bug for setting up an actions column in the holdings table.
Comment 19 Galen Charlton 2014-02-26 16:14:56 UTC
(In reply to Galen Charlton from comment #18)
> I will open a new bug for setting up an actions column in the holdings table.

Bug 11851.
Comment 20 Christopher Brannon 2014-02-26 17:19:51 UTC
*** Bug 11840 has been marked as a duplicate of this bug. ***
Comment 21 Fridolin SOMERS 2014-06-03 13:45:50 UTC
Pushed to 3.14.x, will be in 3.14.08
(Like in master, concerns only the 2 first patches)