Bug 11768 - Show patron cardnumber in opac personal details
Summary: Show patron cardnumber in opac personal details
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 12418 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-14 20:09 UTC by Kyle M Hall
Modified: 2015-06-04 23:30 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 11768 - Show patron cardnumber in opac personal details (2.81 KB, patch)
2014-02-14 20:11 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 11768 - Show patron cardnumber in opac personal details (2.87 KB, patch)
2014-02-15 07:43 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 11768 - Show patron cardnumber in opac personal details (3.05 KB, patch)
2014-02-23 22:06 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2014-02-14 20:09:02 UTC
In previous versions of Koha, the patron cardnumber was displayed in the personal details section of the opac for logged in users. A patron needs to be able to access his or her cardnumber in some cases to access online resources a library makes available that requires his or her cardnumber. This is especially important for patron self registration where a patron may not have a physical library card. This field should be re-added to the patron personal details page.
Comment 1 Kyle M Hall 2014-02-14 20:11:00 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2014-02-15 07:40:48 UTC
Cardnumber was killed when we switched to the opac-memberentry.tt instead of opac-userupdate.tt (with the self registration stuff)

So around 3.12.0
Comment 3 Chris Cormack 2014-02-15 07:43:38 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2014-02-23 22:06:23 UTC
Created attachment 25565 [details] [review]
[PASSED QA] Bug 11768 - Show patron cardnumber in opac personal details

In previous versions of Koha, the patron cardnumber was displayed in the
personal details section of the opac for logged in users. A patron needs
to be able to access his or her cardnumber in some cases to access
online resources a library makes available that requires his or her
cardnumber. This is especially important for patron self registration
where a patron may not have a physical library card. This field should
be re-added to the patron personal details page.

Test Plan:
1) Apply this patch
2) Log into the opac
3) Browse to "your personal details"
4) Verify the patron cardnumber is visible

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Restores cardnumber on personal details tab in OPAC for
prog and bootstrap theme. Passes all tests and QA script.
Comment 5 Galen Charlton 2014-02-26 17:26:24 UTC
Pushed to master.  Thanks, Kyle!
Comment 6 Fridolin SOMERS 2014-06-04 07:45:18 UTC
Pushed to 3.14.x, will be in 3.14.08
Comment 7 Nicole C. Engard 2014-07-03 15:20:39 UTC
*** Bug 12418 has been marked as a duplicate of this bug. ***