Bug 11979 - Display correct not for loan status description on course reserves
Summary: Display correct not for loan status description on course reserves
Status: RESOLVED DUPLICATE of bug 12302
Alias: None
Product: Koha
Classification: Unclassified
Component: Course reserves (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
: 18358 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-20 19:15 UTC by Marjorie Barry-Vila
Modified: 2019-08-18 20:48 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
not for loan reserve (108.01 KB, image/png)
2014-04-02 13:55 UTC, Marjorie Barry-Vila
Details
not for loan reserve (156.70 KB, image/png)
2014-04-02 13:56 UTC, Marjorie Barry-Vila
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marjorie Barry-Vila 2014-03-20 19:15:03 UTC
Hi,

Status not for loan of an item is not showing on opac-course-detail.
Exemple here http://catalog.bywatersolutions.com/cgi-bin/koha/opac-detail.pl?biblionumber=47957 and http://catalog.bywatersolutions.com/cgi-bin/koha/opac-course-details.pl?course_id=1

Status is not for loan on opac-detail and available on opac-course-details.

Is this normal? 

Regards,

Marjorie
Comment 1 Marjorie Barry-Vila 2014-04-02 13:55:36 UTC
Created attachment 26763 [details]
not for loan reserve
Comment 2 Marjorie Barry-Vila 2014-04-02 13:56:02 UTC
Created attachment 26764 [details]
not for loan reserve
Comment 3 Katrin Fischer 2014-05-19 06:04:53 UTC
Hi Marjorie, 

I think the display in the course reserves list only distinguishes between available (on the shelf) and checked out.
Comment 4 Owen Leonard 2016-08-09 18:05:39 UTC
Is there a reason why the list of course reserves /shouldn't/ show the true status of an item?
Comment 5 Katrin Fischer 2016-08-10 06:51:35 UTC
Hm, you are right - it should be the same as on the detail page I think. Showing 'ordered' and all the other status.
Comment 6 Owen Leonard 2016-08-19 18:54:14 UTC
It turns out the template /tries/ to show the correct not for loan status, but the notforloan data which is passed to item-status.inc is incomplete. Compare the item data pulled by GetBiblioFromItemNumber in Biblio.pm (from which the course reserves information comes) to GetItemsInfo in Items.pm (from which the item data comes for pages like opac-detail.pl).
Comment 7 Owen Leonard 2017-05-04 12:37:58 UTC
*** Bug 18358 has been marked as a duplicate of this bug. ***
Comment 8 Myka Kennedy Stephens 2019-08-02 14:00:20 UTC
I am noticing the effects of this bug, too. We would like to add items to courses while they are on order, before they have been received and cataloged. In 18.11, the status "Not for loan (Ordered)" shows as "Available" in the OPAC course reserves list view.
Comment 9 Katrin Fischer 2019-08-18 20:48:19 UTC
Marking as duplicate with the other not-for-loan/course reserves bug.

*** This bug has been marked as a duplicate of bug 12302 ***