Bug 12094 - jQueryUI upgrade broke default tab selection
Summary: jQueryUI upgrade broke default tab selection
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
Depends on: 11570
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-16 13:34 UTC by Owen Leonard
Modified: 2015-06-04 23:30 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12094 - jQueryUI upgrade broke default tab selection (9.97 KB, patch)
2014-04-16 14:57 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED OFF] Bug 12094 - jQueryUI upgrade broke default tab selection (10.26 KB, patch)
2014-04-21 15:50 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 12094 - jQueryUI upgrade broke default tab selection (10.41 KB, patch)
2014-04-22 11:11 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2014-04-16 13:34:25 UTC
Another unforeseen consequence of the jQueryUI upgrade: default tab select is broken. This is most visible on the search results page where the "search the catalog" tab should be selected by default but isn't.
Comment 1 Owen Leonard 2014-04-16 14:57:40 UTC Comment hidden (obsolete)
Comment 2 M. Tompsett 2014-04-21 15:50:15 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-04-22 11:11:26 UTC
Created attachment 27390 [details] [review]
Bug 12094 - jQueryUI upgrade broke default tab selection

The recent upgrade to jQueryUI didn't take into account the new method
for forcing selection of a tab by adding a class to the tab markup. This
patch corrects this by updating the class name.

This patch also updates one instance where it was necessary to switch to
the new function for selecting a tab by ID, introduced by Bug 12075.

To test, view the following pages:

- Perform a catalog search in the staff client. On the search results
  page the "Search the catalog" tab should be selected.

- In Acquisitions, view the basket groups page for a vendor which has
  open and closed basket groups
  (/cgi-bin/koha/acqui/basketgroup.pl?booksellerid=X). Append
  "&listclosed=1" to the URL. The "Closed" tab should be selected.

- In Administration -> Authorized values, modify an authorized value for
  which an icon has been selected. When the edit form loads the
  corresponding icon tab should be selected.

- In Administration -> Item types, modify an itemtype for which an icon
  has been selected. When the edit form loads the corresponding icon tab
  should be selected.

- In Cataloging, open an existing record and select any tab besides the
  first one. Choose "Save and continue editing" from the Save menu. When
  the page reloads you should be returned to the tab you selected
  before.

- In Suggestions, markup for selected the tab has been removed because
  it didn't appear to be performing any function. The first tab is
  selected by default. The template doesn't need to explicitly add a
  class to make it so.

- In Tools -> CSV profiles, choose an existing profile for editing. When
  the page loads the "Edit existing profile" tab should be selected.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

NOTE: Unable to duplicate Cataloging step issue, but there is no
      visible regression with the patch. The second part of the
      addbiblio.tt portion of the patch is clearly correct,
      because it is the same type of change as made in the other
      sections.

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 4 Galen Charlton 2014-04-22 14:53:50 UTC
Pushed to master.  Thanks, Owen!
Comment 5 Fridolin SOMERS 2014-06-19 15:18:37 UTC
Pushed to 3.14.x, will be in 3.14.08