Bug 12352 - Patron modification request page: Add link to patron record
Summary: Patron modification request page: Add link to patron record
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Katrin Fischer
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 14864 (view as bug list)
Depends on: 13349
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-03 04:30 UTC by paxed
Modified: 2017-06-14 22:10 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 12352: Patron modification request page: Add link to patron record (2.85 KB, patch)
2015-06-09 23:47 UTC, Katrin Fischer
Details | Diff | Splinter Review
[Signed-off] Bug 12352: Patron modification request page: Add link to patron record (3.05 KB, patch)
2015-06-10 05:23 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 12352: Patron modification request page: Add link to patron record (3.20 KB, patch)
2015-06-16 15:56 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description paxed 2014-06-03 04:30:47 UTC
There should be a link to the patron details on the "Update patron records" -page. This would make it much easier for the staff to check on the patron information.
Comment 1 Justin Vos 2015-01-13 20:23:11 UTC
I've started working on this bug.
Justin Vos
Comment 2 Justin Vos 2015-01-14 21:27:27 UTC
I'm not sure what is required here. While editing a patron's details in the staff client, there is already a link back to the patron's details page in the left side-bar named "Details".

Is the link needed somewhere else?
Comment 3 Katrin Fischer 2015-01-14 21:29:23 UTC
Hi Justin, try the following: 
- go to the patron account from the OPAC
- enter an address change request from the details page there
- see that a note appears in the patron module and on the start page of the staff client
- the entry asking to moderate the modification is the one to change
Comment 4 Katrin Fischer 2015-06-09 23:47:44 UTC Comment hidden (obsolete)
Comment 5 Marc Véron 2015-06-10 05:23:57 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2015-06-16 15:56:22 UTC
Created attachment 40191 [details] [review]
Bug 12352: Patron modification request page: Add link to patron record

The patron modification request page in the staff client does show
the name and home library of a patron, but there is no way to
go to the patron record. This patch adds a link to the patron details.

Extras: changes display of patron name, so a missing firstname won't
result in an extra , showing.

To test:
- Make some update requests from different patron accounts in the OPAC
- Go to the patron modification request page in staff
- Verify a link 'Patron details' now shows on each entry and
  works correctly

Followed test plan. Works as expected. QA tools OK.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Jonathan Druart <jonathan.druart@koha-community.org>
Not sure the "Patron details" link is at the best place, but I don't
have something better to suggest.
Comment 7 Katrin Fischer 2015-06-16 16:36:52 UTC
Agreed - but as the name in the tab is already a link for the 'accordeon' effect, there was no other obvious spot I could think of.
Comment 8 Tomás Cohen Arazi 2015-07-20 13:26:29 UTC
Patch pushed to master.

Thanks Katrina!
Comment 9 Lari Taskula 2015-09-21 14:42:58 UTC
*** Bug 14864 has been marked as a duplicate of this bug. ***