Bug 12987 - Update table footer with the visible rows
Summary: Update table footer with the visible rows
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 24454 (view as bug list)
Depends on: 12844 12986
Blocks: 23767 12988 12989
  Show dependency treegraph
 
Reported: 2014-09-24 15:09 UTC by Jonathan Druart
Modified: 2020-01-31 14:42 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 12987: Update table footer with the visible rows (12.55 KB, patch)
2014-09-24 15:11 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 12987: Update table footer with the visible rows (3.70 KB, patch)
2014-09-24 15:16 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 12987: The new format_price include file should be include on using datatables (857 bytes, patch)
2014-10-02 13:52 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 12987: Fix remove all what is not number (1.08 KB, patch)
2014-10-06 18:19 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 12987: Update table footer with the visible rows (3.75 KB, patch)
2014-10-09 15:30 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 12987: The new format_price include file should be include on using datatables (913 bytes, patch)
2014-10-09 15:30 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 12986: Upgrade the DataTables jQuery plugin to the latest version (1.10.2) (292.33 KB, patch)
2014-10-27 22:43 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 12987: Update table footer with the visible rows (3.82 KB, patch)
2014-10-27 22:43 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 12987: Update table footer with the visible rows (3.82 KB, patch)
2014-10-27 22:44 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 12987: The new format_price include file should be include on using datatables (983 bytes, patch)
2014-10-27 22:44 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-09-24 15:09:38 UTC
For instance, on acqui/acqui-home.pl and admin/aqbudgets.pl, it would be great to see the totals in the footer updated with the filtered rows.

This patch will offer the possibility to do that.
Comment 1 Jonathan Druart 2014-09-24 15:11:52 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2014-09-24 15:16:39 UTC Comment hidden (obsolete)
Comment 3 Jonathan Druart 2014-10-02 13:52:34 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2014-10-06 18:19:52 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2014-10-07 18:01:44 UTC
Last patch is stupid, it does not take into account decimal prices.
Comment 6 Jonathan Druart 2014-10-08 20:48:31 UTC
To test this patch (actually bug 12988 and bug 12989), you need to apply bug 12844 (and bug 12979).
I forgot this dependency, that's why it does not work.
Bug 12844 removes the currency symbol on the aqbudgets page. The problem arises if the currency symbol is displayed.
It could (and will) be fixed later.
I cannot fix everything without to be sure these patches will be pushed.
Comment 7 Chris Cormack 2014-10-09 15:29:36 UTC
In the future we might need to extend the IF to handle other ones, but for now that is no reason not to sign off
Comment 8 Chris Cormack 2014-10-09 15:30:27 UTC Comment hidden (obsolete)
Comment 9 Chris Cormack 2014-10-09 15:30:49 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2014-10-27 22:39:30 UTC
More bread crumbs - This can only be tested with another bug, so apply first bug 12984 and then bug 12989.
Comment 11 Katrin Fischer 2014-10-27 22:43:10 UTC Comment hidden (obsolete)
Comment 12 Katrin Fischer 2014-10-27 22:43:25 UTC Comment hidden (obsolete)
Comment 13 Katrin Fischer 2014-10-27 22:44:16 UTC
Created attachment 32814 [details] [review]
[PASSED QA] Bug 12987: Update table footer with the visible rows

This patch is the preparation step for others.

On acqui/acqui-home.pl and admin/aqbudgets.pl, it will be possible to
see the totals in the footer updated with the filtered rows.

Test plan:
This cannot be tested alone, you have to apply it with others (see the
"Blocked" bug reports).

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 14 Katrin Fischer 2014-10-27 22:44:43 UTC
Created attachment 32815 [details] [review]
[PASSED QA] Bug 12987: The new format_price include file should be include on using datatables

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Tomás Cohen Arazi 2014-11-11 12:58:36 UTC
Patches pushed to master.

Thanks Jonathan!
Comment 16 Tomás Cohen Arazi 2020-01-31 14:42:28 UTC
*** Bug 24454 has been marked as a duplicate of this bug. ***