Bug 13155 - Course reserves doesn't display reserved items on OPAC
Summary: Course reserves doesn't display reserved items on OPAC
Status: RESOLVED DUPLICATE of bug 12302
Alias: None
Product: Koha
Classification: Unclassified
Component: Course reserves (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Frédéric Demians
QA Contact: Testopia
URL:
Keywords:
Depends on: 12302
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-28 17:49 UTC by Frédéric Demians
Modified: 2014-10-28 18:10 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Course reserves empty table (21.26 KB, image/png)
2014-10-28 17:52 UTC, Frédéric Demians
Details
Bug 13155 Course reserves doesn't display reserved items on OPAC (1.80 KB, patch)
2014-10-28 17:53 UTC, Frédéric Demians
Details | Diff | Splinter Review
Course reserves table after patch (23.15 KB, image/png)
2014-10-28 17:55 UTC, Frédéric Demians
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Demians 2014-10-28 17:49:59 UTC
On OPAC, opac-course-details.pl page, when a specific course reserves is
selected, all its items are displayed in a table with several columns: title,
item type, location, etc. Nothing is displayed in those columns, except the
item status.
Comment 1 Frédéric Demians 2014-10-28 17:52:36 UTC
Created attachment 32848 [details]
Course reserves empty table
Comment 2 Frédéric Demians 2014-10-28 17:53:50 UTC
Created attachment 32849 [details] [review]
Bug 13155 Course reserves doesn't display reserved items on OPAC

On OPAC, opac-course-details.pl page, when a specific course reserves is
selected, all its items are displayed in a table with several columns: titel,
item type, location, etc. Nothing is displayed in those columns, except the
item status.

TEST PLAN:

- If you haven't already a course reserves, create one:

  - Enable course reserves with syspref UseCourseReserves
  - Create a course reserves
  - Add an item to your course reserves

- On OPAC, click on Course Reserves, then select a course

- The item table is empty

- Apply the patch, refresh the OPAC page: item table contains info
Comment 3 Frédéric Demians 2014-10-28 17:55:25 UTC
Created attachment 32850 [details]
Course reserves table after patch
Comment 4 Frédéric Demians 2014-10-28 18:03:51 UTC
Bug 12302 is required by this one.
Comment 5 Frédéric Demians 2014-10-28 18:10:26 UTC
Rather than providing a fix on a separate bug#, I will provide a alt patch to bug 12302.

*** This bug has been marked as a duplicate of bug 12302 ***