Bug 13190 - Export checkout list does not work anymore
Summary: Export checkout list does not work anymore
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.16
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 11703
Blocks: 12404 18136
  Show dependency treegraph
 
Reported: 2014-11-03 16:26 UTC by Jonathan Druart
Modified: 2017-02-17 09:56 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13190: Reintroduce the checkouts export feature (11.70 KB, patch)
2014-11-03 16:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13190: Reintroduce the checkouts export feature (14.59 KB, patch)
2014-11-03 17:17 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13190: Reintroduce the checkouts export feature (15.47 KB, patch)
2014-11-03 17:22 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13190: Refactor the checkouts table template code (14.88 KB, patch)
2014-11-04 08:35 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 13190 [QA Followup] - Fix koha-qa.pl violations (2.14 KB, patch)
2014-11-04 17:07 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13190: Reintroduce the checkouts export feature (15.54 KB, patch)
2014-11-04 18:06 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13190: Reintroduce the checkouts export feature (15.54 KB, patch)
2014-11-04 18:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13190: Refactor the checkouts table template code (14.96 KB, patch)
2014-11-04 18:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 13190 [QA Followup] - Fix koha-qa.pl violations (2.20 KB, patch)
2014-11-04 18:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
[PASSED QA] Bug 13190: Reintroduce the checkouts export feature (15.59 KB, patch)
2014-11-05 20:31 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 13190: Refactor the checkouts table template code (14.98 KB, patch)
2014-11-05 20:32 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-11-03 16:26:28 UTC
Bug 11703 breaks the export feature present on the checkout list.

On circ/circulation.pl, the export column is there but not the export button.
Comment 1 Jonathan Druart 2014-11-03 16:39:54 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2014-11-03 16:51:55 UTC
It does not work.
Comment 3 Jonathan Druart 2014-11-03 17:17:12 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2014-11-03 17:22:44 UTC Comment hidden (obsolete)
Comment 5 Owen Leonard 2014-11-03 19:24:25 UTC
If you do not have "Always show checkouts immediately" checked by default, the list of checkouts doesn't appear but the "export checkouts" form does. However, the "export checkouts" function doesn't work unless you have selected checkouts to export.

I think the export form should be hidden by default along with the checkouts.
Comment 6 Jonathan Druart 2014-11-04 08:35:46 UTC Comment hidden (obsolete)
Comment 7 Jonathan Druart 2014-11-04 08:37:41 UTC
(In reply to Owen Leonard from comment #5)
> If you do not have "Always show checkouts immediately" checked by default,
> the list of checkouts doesn't appear but the "export checkouts" form does.

It worked on a view, not on the other. I copy the duplicated code into an include file in order to avoid this mistake later.

> However, the "export checkouts" function doesn't work unless you have
> selected checkouts to export.

You would like to export all checkouts, that's it?
This behavior is the same as before I think.
Comment 8 Kyle M Hall 2014-11-04 17:07:17 UTC Comment hidden (obsolete)
Comment 9 Kyle M Hall 2014-11-04 18:06:16 UTC Comment hidden (obsolete)
Comment 10 Kyle M Hall 2014-11-04 18:08:11 UTC Comment hidden (obsolete)
Comment 11 Kyle M Hall 2014-11-04 18:08:18 UTC Comment hidden (obsolete)
Comment 12 Kyle M Hall 2014-11-04 18:08:20 UTC Comment hidden (obsolete)
Comment 13 Kyle M Hall 2014-11-04 18:09:53 UTC
> > However, the "export checkouts" function doesn't work unless you have
> > selected checkouts to export.
> 
> You would like to export all checkouts, that's it?
> This behavior is the same as before I think.

I can confirm this is the original behavior ( as of 3.16.2 ).
Comment 14 Katrin Fischer 2014-11-05 20:31:49 UTC
Created attachment 33270 [details] [review]
[PASSED QA] Bug 13190: Reintroduce the checkouts export feature

Bug 11703 breaks the checkouts export feature.

To reproduce: Fill the ExportWithCsvProfile pref and go on the
circ/circulation.pl page. The export column appears, but not the export
button.

Test plan:
Go on the checkout list (circ/circulation.pl and members/moremember.pl)
and verify the export column and the export button appears.
If you click on the button, a file should be generated.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 15 Katrin Fischer 2014-11-05 20:32:19 UTC
Created attachment 33271 [details] [review]
[PASSED QA] Bug 13190: Refactor the checkouts table template code

This code is duplicated and should be centralised.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 16 Katrin Fischer 2014-11-05 20:36:02 UTC
Jonathan, is it possible that exporting today's check ins (using the entry in the toolbar) is also not working? I am not sure if I am missing configuraton. I returned some items and tried exporting, the file is empty.
Comment 17 Liz Rea 2014-11-05 22:21:41 UTC
I tested the "export today's checkins" two ways:

using the "check in" page - works as expected from a borrower who had returns that day

using the tickboxes on the circulation screen and clicking "Return or renew items" (after clicking "show checkouts") - worked as expected for that borrower.

I noted that borrowers that don't have any checkins today get an empty file, I assume that is how the feature is intended to work.

Katrin - I hope this helps. :)

Liz
Comment 18 Tomás Cohen Arazi 2014-11-06 13:28:38 UTC
Patches pushed to master.

Thanks Jonathan!
Comment 19 Mason James 2015-01-16 19:53:08 UTC
potential inclusion for 3.16.x
Comment 20 Mason James 2015-01-19 13:22:34 UTC
Pushed to 3.16.x, will be in 3.16.7