Bug 13475 - OAI does not return items
Summary: OAI does not return items
Status: RESOLVED DUPLICATE of bug 12252
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 5579
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-17 16:19 UTC by Jonathan Druart
Modified: 2014-12-18 10:34 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 13475: OAI should return items (2.93 KB, patch)
2014-12-17 16:23 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2014-12-17 16:19:49 UTC
Since bug 5579, items are not stored in DB.
The oai script does not have been changed.
Comment 1 Jonathan Druart 2014-12-17 16:23:02 UTC
Created attachment 34486 [details] [review]
Bug 13475: OAI should return items

Since bug 5579, items are not stored in DB.
The oai script does not have been changed.

Test plan:
go on
1/ Enable the pref OAI-PMH
2/ Set OAI-PMH:archiveID = KOHA-OAI-TEST (or what you want)
3/ Go on
oai.pl?verb=GetRecord&metadataPrefix=marcxml&identifier=KOHA-OAI-TEST:[BIBLIONUMBER]
with [BIBLIONUMBER] a record's biblionumber containing items.
The marcxml should be returned with items.
Comment 2 Katrin Fischer 2014-12-17 20:53:54 UTC
Hi Jonathan, I think this is duplicate to 12252 - can you check the other implementation? It's waiting for QA :)
Comment 3 Jonathan Druart 2014-12-18 10:34:19 UTC
(In reply to Katrin Fischer from comment #2)
> Hi Jonathan, I think this is duplicate to 12252 - can you check the other
> implementation? It's waiting for QA :)

Yes it is, thanks.

*** This bug has been marked as a duplicate of bug 12252 ***