Bug 13835 - Popup with searches: results hidden by language menu in footer
Summary: Popup with searches: results hidden by language menu in footer
Status: Pushed to Stable
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Whiteboard:
Keywords:
: 13837 (view as bug list)
Depends on:
Blocks: 18483
  Show dependency treegraph
 
Reported: 2015-03-14 15:58 UTC by Marc Véron
Modified: 2017-05-24 02:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Popup window on a wide screen (27.70 KB, image/png)
2017-04-21 18:17 UTC, Marc Véron
Details
Popup window on a narrower screen (14.28 KB, image/png)
2017-04-21 18:18 UTC, Marc Véron
Details
Bug 13835: Popup with searches: results hidden by language menu in footer (2.74 KB, patch)
2017-04-21 19:45 UTC, Marc Véron
Details | Diff | Splinter Review
Bug 13835: Popup with searches: results hidden by language menu in footer (2.84 KB, patch)
2017-04-24 00:05 UTC, Alex Buckley
Details | Diff | Splinter Review
Bug 13835: Popup with searches: results hidden by language menu in footer (2.91 KB, patch)
2017-04-24 17:41 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Véron 2015-03-14 15:58:35 UTC
To verify:

Go to Home > Administration > Funds and edit a fund

Click on "Edit owner"

The popup displays a form "Search for budget owner" with language selection in footer. This language selection is not nexessary here.
Comment 1 Marc Véron 2016-02-19 16:14:08 UTC
Language selection is part of intranet-bottom.inc

A fix of this rather cosmetic issue would need to create a separate 'bottom.inc' for such popups.

Setting to RESOLVED WONTFIX
Comment 2 Marc Véron 2017-04-21 18:17:00 UTC
Created attachment 62557 [details]
Popup window on a wide screen

On a wide screen results are visible
Comment 3 Marc Véron 2017-04-21 18:18:05 UTC
Created attachment 62558 [details]
Popup window on a narrower screen

Language selector turns into a list and hides the results
Comment 4 Marc Véron 2017-04-21 18:19:03 UTC
Reopend because the behaviour of language selector changed. It is no longer a cosmetic issue.
Comment 5 Marc Véron 2017-04-21 19:45:27 UTC
Created attachment 62559 [details] [review]
Bug 13835: Popup with searches: results hidden by language menu in footer

Language menus in pop up windows are not necessary and can hide the contents
(especially search results) on a narrow screen.

For an example, see screenshot in comment #3

This patch allows to mark pop p menus not to display the language footer.

To test:

- Reproduce issue from comment #3
- Apply patch
- Try to reproduce issue from comment #3
  -> language menu should no longer display
- Verify that language menu is suppresed in 'Add to ist' as well
  (from catalog search results, select an item, Add to:...)

Note: There will be more pop-ups with unwnated language selector.
      That can be resolved in follow up bugs.
Comment 6 Alex Buckley 2017-04-24 00:05:11 UTC
Created attachment 62582 [details] [review]
Bug 13835: Popup with searches: results hidden by language menu in footer

Language menus in pop up windows are not necessary and can hide the contents
(especially search results) on a narrow screen.

For an example, see screenshot in comment #3

This patch allows to mark pop p menus not to display the language footer.

To test:

- Reproduce issue from comment #3
- Apply patch
- Try to reproduce issue from comment #3
  -> language menu should no longer display
- Verify that language menu is suppresed in 'Add to ist' as well
  (from catalog search results, select an item, Add to:...)

Note: There will be more pop-ups with unwnated language selector.
      That can be resolved in follow up bugs.

Followed test plan which worked as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>
Comment 7 Jonathan Druart 2017-04-24 17:40:50 UTC
*** Bug 13837 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Druart 2017-04-24 17:41:35 UTC
Created attachment 62626 [details] [review]
Bug 13835: Popup with searches: results hidden by language menu in footer

Language menus in pop up windows are not necessary and can hide the contents
(especially search results) on a narrow screen.

For an example, see screenshot in comment #3

This patch allows to mark pop p menus not to display the language footer.

To test:

- Reproduce issue from comment #3
- Apply patch
- Try to reproduce issue from comment #3
  -> language menu should no longer display
- Verify that language menu is suppresed in 'Add to ist' as well
  (from catalog search results, select an item, Add to:...)

Note: There will be more pop-ups with unwnated language selector.
      That can be resolved in follow up bugs.

Followed test plan which worked as intended
Signed-off-by: Alex Buckley <alexbuckley@catalyst.net.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 9 Kyle M Hall 2017-04-28 12:35:37 UTC
Pushed to master for 17.05, thanks Marc!
Comment 10 Katrin Fischer 2017-05-13 12:27:45 UTC
This patch has been pushed to 16.11.x and will be in 16.11.08.
Comment 11 Mason James 2017-05-24 02:09:38 UTC
Pushed to 16.05.x, for 16.05.13 release